summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-02-01 17:01:21 +0100
committerJeroen Roovers <jer@gentoo.org>2016-02-01 17:14:08 +0100
commit86c0b4ec70200da8e9f4dc043a12ff7b60bea2ae (patch)
tree3e1485751acde6b1a0e41165c1b4162e17b4332d /net-misc/socat/socat-2.0.0_beta9.ebuild
parentapp-shells/zsh: add alpha keyword (diff)
downloadgentoo-86c0b4ec70200da8e9f4dc043a12ff7b60bea2ae.tar.gz
gentoo-86c0b4ec70200da8e9f4dc043a12ff7b60bea2ae.tar.bz2
gentoo-86c0b4ec70200da8e9f4dc043a12ff7b60bea2ae.zip
net-misc/socat: Version bump.
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-misc/socat/socat-2.0.0_beta9.ebuild')
-rw-r--r--net-misc/socat/socat-2.0.0_beta9.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-misc/socat/socat-2.0.0_beta9.ebuild b/net-misc/socat/socat-2.0.0_beta9.ebuild
new file mode 100644
index 000000000000..eb6735580dcb
--- /dev/null
+++ b/net-misc/socat/socat-2.0.0_beta9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/"
+MY_P=${P/_beta/-b}
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="ssl readline ipv6 tcpd"
+
+DEPEND="
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/readline-4.1 )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+DOCS=(
+ BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY
+)
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.7.3.0-filan-build.patch
+ touch doc/${PN}.1 || die
+}
+
+src_configure() {
+ filter-flags -Wall '-Wno-error*' #293324
+ tc-export AR
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable readline) \
+ $(use_enable ipv6 ip6) \
+ $(use_enable tcpd libwrap)
+}
+
+src_install() {
+ default
+
+ dohtml doc/*.html doc/*.css
+}