summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2019-10-21 09:38:57 +0800
committerYixun Lan <dlan@gentoo.org>2019-10-21 09:39:18 +0800
commit6853874c1dcb82f5f5b8c55f8b8017f33f8c41c8 (patch)
tree12b5d29bc606ebd071c24af70c5cc71299655e35 /net-misc/ofono
parentdev-util/crash: drop trailing line to make CI happy (diff)
downloadgentoo-6853874c1dcb82f5f5b8c55f8b8017f33f8c41c8.tar.gz
gentoo-6853874c1dcb82f5f5b8c55f8b8017f33f8c41c8.tar.bz2
gentoo-6853874c1dcb82f5f5b8c55f8b8017f33f8c41c8.zip
net-misc/ofono: version bump, 1.30
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'net-misc/ofono')
-rw-r--r--net-misc/ofono/Manifest1
-rw-r--r--net-misc/ofono/ofono-1.30.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/net-misc/ofono/Manifest b/net-misc/ofono/Manifest
index eee7058157a8..0dd6fed1abb3 100644
--- a/net-misc/ofono/Manifest
+++ b/net-misc/ofono/Manifest
@@ -1,3 +1,4 @@
DIST ofono-1.16.tar.xz 854296 BLAKE2B 4ee8f895e21903b8181fe14f5a91fea466eb3a2f66c8a5ab270a8dd81c601dc5e2a1beae368cf0f14b556f0dfb8301439d40d93bfd1d058d43ce864cdd1f0788 SHA512 21887e1bc3b8af18881f9456f950b97885b567164e28ebe2ab6fc5a3042c439891a20b5034a8fa0c7a78567286ac53c1b8a72122f428fbcf5da8bf139423b913
DIST ofono-1.28.tar.xz 1016308 BLAKE2B 0aec5bc6c845c0906548f62bda95bfee5ca5ef17bc2defd60fe4b0967b9f58fcbbbfeb9593aa33f6852360266ea4ea025a87a07ac95ef50829b592accfb5bc72 SHA512 963471fac89db746d0e99fee805413342203be0d200bc14f0e56c5ec3053e25ea8112943657c88c57c539ae485ac11eb5f80052aad12443c248888f6e6a4114e
DIST ofono-1.29.tar.xz 1019512 BLAKE2B e073f324c58fee1beac31ba685d92ee85814ccb072aaedc0fa2d0d25419d60449557fcabd0e1b3e5aad6c349582a2abe6fb69094f36b61dbea0f94ed0f8dff4e SHA512 14c3cd3a7ee134dd85f286e3ce47914a10c48a9a2bbbebd0d2715334f233a9b7e4e01bae5a151e4f4b3fb3e98eab96ba345f3fb2c2960d2f9c0645f36c218a99
+DIST ofono-1.30.tar.xz 1030428 BLAKE2B 94248b7eb7b48000333fdee38eaecf13c259adf2ca71946a25c06463abc052c568974981b0116ef5e006a6bd9f106a0bf2a5d2b1f9ad06beaffceff6cb3bbde4 SHA512 e65c5af7f09eef31c1e8c2b8202315b1bfeeb18e6e3cca07e3758ee693e51f8d8007211cba9e0da17656b063f362858a51234908c89a2bfd1ef0e057d538bda5
diff --git a/net-misc/ofono/ofono-1.30.ebuild b/net-misc/ofono/ofono-1.30.ebuild
new file mode 100644
index 000000000000..406ed49a7a36
--- /dev/null
+++ b/net-misc/ofono/ofono-1.30.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils multilib systemd
+
+DESCRIPTION="Open Source mobile telephony (GSM/UMTS) daemon"
+HOMEPAGE="https://01.org/ofono"
+SRC_URI="https://www.kernel.org/pub/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+atmodem bluetooth +cdmamodem +datafiles doc dundee examples +isimodem +phonesim +provision +qmimodem tools +udev upower"
+
+REQUIRED_USE="dundee? ( bluetooth )"
+
+RDEPEND=">=sys-apps/dbus-1.4
+ >=dev-libs/glib-2.32
+ net-misc/mobile-broadband-provider-info
+ bluetooth? ( >=net-wireless/bluez-4.99 )
+ udev? ( virtual/udev )
+ examples? ( dev-python/dbus-python )
+ tools? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( ChangeLog AUTHORS )
+
+src_configure() {
+ econf \
+ $(use_enable udev) \
+ $(use_enable isimodem) \
+ $(use_enable atmodem) \
+ $(use_enable cdmamodem) \
+ $(use_enable datafiles) \
+ $(use_enable dundee) \
+ $(use_enable bluetooth) \
+ $(use_enable phonesim) \
+ $(use_enable provision) \
+ $(use_enable qmimodem) \
+ $(use_enable tools) \
+ $(use_enable examples test) \
+ $(use_enable upower) \
+ --disable-maintainer-mode \
+ --disable-rilmodem
+ --localstatedir=/var \
+ --with-systemdunitdir="$(systemd_get_systemunitdir)"
+}
+
+src_install() {
+ default
+
+ if use tools ; then
+ dobin tools/auto-enable \
+ tools/huawei-audio \
+ tools/lookup-provider-name \
+ tools/lookup-apn \
+ tools/get-location \
+ tools/tty-redirector
+ fi
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ use doc && dodoc doc/*.txt
+}