summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaul E Rangel <rrangel@chromium.org>2023-08-15 10:53:30 -0600
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-25 15:55:02 +0300
commitc5bc79e914e90097efade012df40509baf5cf5f2 (patch)
tree901950ff420873c6a038124d3eda180487d68158 /net-analyzer/netperf/netperf-2.7.0-r5.ebuild
parentgames-util/cartridges: Stabilize 2.2.1 amd64, #914654 (diff)
downloadgentoo-c5bc79e914e90097efade012df40509baf5cf5f2.tar.gz
gentoo-c5bc79e914e90097efade012df40509baf5cf5f2.tar.bz2
gentoo-c5bc79e914e90097efade012df40509baf5cf5f2.zip
net-analyzer/netperf: Fix dependencies
The acct- dependencies should be BDEPEND instead of DEPEND. We also need gnuconfig so that the config.sub will get patched with `econf`. Otherwise we get the following error: ``` configure: loading site script /usr/share/config.site configure: loading site script /usr/share/crossdev/include/site/linux configure: loading site script /usr/share/crossdev/include/site/linux-gnu checking build system type... x86_64-pc-linux-gnu checking host system type... Invalid configuration `aarch64-cros-linux-gnu': machine `aarch64-cros' not recognized configure: error: /bin/sh ./config.sub aarch64-cros-linux-gnu failed ``` vs a good run that has gnuconfig installed prints the following: ``` >>> Configuring source in /build/arm64-generic/tmp/portage/net-analyzer/netperf-2.7.0-r4/work/netperf-2.7.0 ... * econf: updating netperf-2.7.0/config.guess with /usr/share/gnuconfig/config.guess * econf: updating netperf-2.7.0/config.sub with /usr/share/gnuconfig/config.sub ``` Signed-off-by: Raul E Rangel <rrangel@chromium.org> Closes: https://github.com/gentoo/gentoo/pull/32326 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'net-analyzer/netperf/netperf-2.7.0-r5.ebuild')
-rw-r--r--net-analyzer/netperf/netperf-2.7.0-r5.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/net-analyzer/netperf/netperf-2.7.0-r5.ebuild b/net-analyzer/netperf/netperf-2.7.0-r5.ebuild
new file mode 100644
index 000000000000..b66c8514fe1b
--- /dev/null
+++ b/net-analyzer/netperf/netperf-2.7.0-r5.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Network performance benchmark"
+HOMEPAGE="http://www.netperf.org/"
+SRC_URI="ftp://ftp.netperf.org/${PN}/${P}.tar.bz2"
+KEYWORDS="~alpha amd64 arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86"
+
+LICENSE="netperf"
+SLOT="0"
+IUSE="demo sctp"
+
+RDEPEND="
+ acct-group/netperf
+ acct-user/netperf
+"
+BDEPEND="
+ sys-devel/gnuconfig
+ ${RDEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-fix-scripts.patch
+ "${FILESDIR}"/${PN}-2.6.0-log-dir.patch
+ "${FILESDIR}"/${PN}-2.7.0-includes.patch
+ "${FILESDIR}"/${PN}-2.7.0-space.patch
+ "${FILESDIR}"/${PN}-2.7.0-inline.patch
+ "${FILESDIR}"/${PN}-2.7.0-fcommon.patch
+)
+
+src_prepare() {
+ # Fixing paths in scripts
+ sed -i \
+ -e 's:^\(NETHOME=\).*:\1"/usr/bin":' \
+ doc/examples/sctp_stream_script \
+ doc/examples/tcp_range_script \
+ doc/examples/tcp_rr_script \
+ doc/examples/tcp_stream_script \
+ doc/examples/udp_rr_script \
+ doc/examples/udp_stream_script \
+ || die
+
+ default
+}
+
+src_configure() {
+ # netlib.c:2292:5: warning: implicit declaration of function ‘sched_setaffinity’
+ # nettest_omni.c:2943:5: warning: implicit declaration of function ‘splice’
+ # TODO: drop once https://github.com/HewlettPackard/netperf/pull/73 merged
+ append-cppflags -D_GNU_SOURCE
+
+ econf \
+ $(use_enable demo) \
+ $(use_enable sctp)
+}
+
+src_install() {
+ default
+
+ # Move netserver into sbin as we had it before 2.4 was released with its
+ # autoconf goodness
+ dodir /usr/sbin
+ mv "${ED}"/usr/{bin,sbin}/netserver || die
+
+ # init.d / conf.d
+ newinitd "${FILESDIR}"/${PN}-2.7.0-init netperf
+ newconfd "${FILESDIR}"/${PN}-2.2-conf netperf
+
+ keepdir /var/log/${PN}
+ fowners netperf:netperf /var/log/${PN}
+ fperms 0755 /var/log/${PN}
+
+ # documentation and example scripts
+ dodoc AUTHORS ChangeLog NEWS README Release_Notes
+ dodir /usr/share/doc/${PF}/examples
+ # Scripts no longer get installed by einstall
+ cp doc/examples/*_script "${ED}"/usr/share/doc/${PF}/examples || die
+}