summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNedko Arnaudov <nedko@nedk.org>2024-01-08 02:10:08 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-01-10 09:45:43 +0100
commit9bb8a74bb9c7df16ac95e2ec7e3843274dd1e052 (patch)
treee7f064517782e2c5b8cf08a1aac5d21c357aba94 /media-sound/a2jmidid
parentdev-java/aspectj: update upstream metadata (diff)
downloadgentoo-9bb8a74bb9c7df16ac95e2ec7e3843274dd1e052.tar.gz
gentoo-9bb8a74bb9c7df16ac95e2ec7e3843274dd1e052.tar.bz2
gentoo-9bb8a74bb9c7df16ac95e2ec7e3843274dd1e052.zip
media-sound/a2jmidid-12: new upstream version; ebuild fixes
Closes: https://bugs.gentoo.org/798411 Closes: https://bugs.gentoo.org/916117 Closes: https://bugs.gentoo.org/914074 Closes: https://bugs.gentoo.org/909411 Closes: https://bugs.gentoo.org/909404 Signed-off-by: Nedko Arnaudov <nedko@nedk.org> Closes: https://github.com/gentoo/gentoo/pull/34706 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/a2jmidid')
-rw-r--r--media-sound/a2jmidid/Manifest1
-rw-r--r--media-sound/a2jmidid/a2jmidid-12.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/media-sound/a2jmidid/Manifest b/media-sound/a2jmidid/Manifest
index 26f2765d5971..edc85bc615c2 100644
--- a/media-sound/a2jmidid/Manifest
+++ b/media-sound/a2jmidid/Manifest
@@ -1 +1,2 @@
+DIST a2jmidid-12.tar.bz2 309227 BLAKE2B 8041bda96cf2bfe3d51cdf9162857e1c484e95581dd132fbe3f582022ecc5ba89bfbe005884646ac8064a62285c16195f2066aadb6841660c2935b245f8bd3b2 SHA512 1556dc5d9ca0a241177246de16f251db815d29ed3bc50b0db7ebededa1d34e5432fddfc7bc85643864ebf641fe95d9040462787962753d60adb8f02a1e94f815
DIST a2jmidid-9.tar.gz 47925 BLAKE2B ad079e76a54f56ee8f82150c306f91aead52f86632978ea6f3376a0bf163744379210b34701b39da4ee14fc4d8a1c6be82d1052abeb8ccf79410bc242d174d62 SHA512 5bd13b6904ed68c5bfe40ca516fd49b7eb4d4a946b9908ee04687265848734c8e1a81579f0f1a5bd0752595be8858dc748da10487b7f366394c09a5ffc7d5e5c
diff --git a/media-sound/a2jmidid/a2jmidid-12.ebuild b/media-sound/a2jmidid/a2jmidid-12.ebuild
new file mode 100644
index 000000000000..1019f69d4611
--- /dev/null
+++ b/media-sound/a2jmidid/a2jmidid-12.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit meson python-single-r1
+
+DESCRIPTION="Daemon for exposing ALSA sequencer applications in JACK MIDI system"
+HOMEPAGE="https://a2jmidid.ladish.org"
+SRC_URI="https://dl.ladish.org/a2jmidid/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="dbus"
+REQUIRED_USE="dbus? ( ${PYTHON_REQUIRED_USE} )"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+CDEPEND="
+ media-libs/alsa-lib
+ virtual/jack
+ dbus? ( sys-apps/dbus ${PYTHON_DEPS} )
+"
+RDEPEND="${CDEPEND}"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS.rst NEWS.rst README internals.txt )
+
+src_configure() {
+ local emesonargs=(
+ -Ddisable-dbus=$(usex dbus false true)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use dbus; then
+ python_fix_shebang "${ED}"
+ fi
+}