summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2023-03-14 11:36:21 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2023-03-14 11:36:54 +0100
commite74ebf33b91fe033f132c5ef269ae336179a8596 (patch)
treeeaf93576154be2cde3f791ec74728fa969de3580 /media-radio/gpredict
parentwww-client/surf: Stabilize 2.1-r3 x86, #900949 (diff)
downloadgentoo-e74ebf33b91fe033f132c5ef269ae336179a8596.tar.gz
gentoo-e74ebf33b91fe033f132c5ef269ae336179a8596.tar.bz2
gentoo-e74ebf33b91fe033f132c5ef269ae336179a8596.zip
media-radio/gpredict: Fix implicit-function-declaration for gethostbyname()
Closes: https://bugs.gentoo.org/896424 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio/gpredict')
-rw-r--r--media-radio/gpredict/files/gpredict-2.3-gethostbyname.patch32
-rw-r--r--media-radio/gpredict/gpredict-2.3-r2.ebuild37
2 files changed, 69 insertions, 0 deletions
diff --git a/media-radio/gpredict/files/gpredict-2.3-gethostbyname.patch b/media-radio/gpredict/files/gpredict-2.3-gethostbyname.patch
new file mode 100644
index 000000000000..5fb7c3f3ef3e
--- /dev/null
+++ b/media-radio/gpredict/files/gpredict-2.3-gethostbyname.patch
@@ -0,0 +1,32 @@
+# MUSL needs _GNU_SOURCE defined to work with gethostbyname()
+# see bug# 896424
+diff --git a/src/gtk-rig-ctrl.c b/src/gtk-rig-ctrl.c
+index 288fa42..25de30c 100644
+--- a/src/gtk-rig-ctrl.c
++++ b/src/gtk-rig-ctrl.c
+@@ -34,6 +34,10 @@
+ #include <build-config.h>
+ #endif
+
++#ifndef _GNU_SOURCE
++#define _GNU_SOURCE
++#endif
++
+ #include <gdk/gdkkeysyms.h>
+ #include <glib.h>
+ #include <glib/gi18n.h>
+diff --git a/src/gtk-rot-ctrl.c b/src/gtk-rot-ctrl.c
+index 5ff5d09..f9e3b4c 100644
+--- a/src/gtk-rot-ctrl.c
++++ b/src/gtk-rot-ctrl.c
+@@ -32,6 +32,10 @@
+ #include <build-config.h>
+ #endif
+
++#ifndef _GNU_SOURCE
++#define _GNU_SOURCE
++#endif
++
+ /* NETWORK */
+ #ifndef WIN32
+ #include <arpa/inet.h> /* htons() */
diff --git a/media-radio/gpredict/gpredict-2.3-r2.ebuild b/media-radio/gpredict/gpredict-2.3-r2.ebuild
new file mode 100644
index 000000000000..cf8fa7dccbcf
--- /dev/null
+++ b/media-radio/gpredict/gpredict-2.3-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Real-time satellite tracking and orbit prediction application"
+HOMEPAGE="http://gpredict.oz9aec.net"
+SRC_URI="https://github.com/csete/gpredict/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gdk-pixbuf[jpeg]
+ x11-libs/gtk+:3
+ x11-libs/goocanvas:2.0
+ net-misc/curl"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README )
+
+src_prepare() {
+ eapply_user
+ # remove wrong doc location
+ eapply "${FILESDIR}/${P}-doc.patch"
+ eapply "${FILESDIR}/${PN}-2.2.1-fno-common.patch"
+ eapply "${FILESDIR}/${PN}-2.3-gethostbyname.patch"
+
+ eautoreconf
+}