summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2016-03-12 16:37:44 +0900
committerAkinori Hattori <hattya@gentoo.org>2016-03-12 16:37:44 +0900
commit8603d9f897304e5b9972bcf5e82c666156831b33 (patch)
tree6bcb477c0fc81c19aea584d128a5961206565ffd /media-libs/libsixel
parentmedia-sound/solfege: update homepage (diff)
downloadgentoo-8603d9f897304e5b9972bcf5e82c666156831b33.tar.gz
gentoo-8603d9f897304e5b9972bcf5e82c666156831b33.tar.bz2
gentoo-8603d9f897304e5b9972bcf5e82c666156831b33.zip
media-libs/libsixel: new upstream release
Package-Manager: portage-2.2.26
Diffstat (limited to 'media-libs/libsixel')
-rw-r--r--media-libs/libsixel/Manifest1
-rw-r--r--media-libs/libsixel/libsixel-1.6.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/libsixel/Manifest b/media-libs/libsixel/Manifest
index 014282838e59..c613eb2864f0 100644
--- a/media-libs/libsixel/Manifest
+++ b/media-libs/libsixel/Manifest
@@ -1 +1,2 @@
DIST libsixel-1.5.2.tar.gz 4731977 SHA256 f83a187a59753873dad630609bd895a33ef566df43ec93c0f8e2605d50ca60d1 SHA512 32d2c2683dcd7ec247d88552204e0bfc2d543565363a85ed965039ce26f8cb98b1d0b18ce5f0a621d161cee52b707d82f40626752490cf8d5ebca3e3e959f289 WHIRLPOOL 089d89e01785600c7b7851d484e142ba305f0d687ab506879283adffc3eb4dfd4c54d999f1590371127731dcb3789c4cc8419c6a3166511cf5bc8ea0a0298d54
+DIST libsixel-1.6.0.tar.gz 4744476 SHA256 06bf22621112f7313d8f5f8a8bec80268969166acae988e449b7cb33883b15c0 SHA512 5e8cfaf67bf8b6b18173f69c230fa75fe7f56448345287ad95716f1e0f45d08a289703eab62897d947c13c13acbf4c08e9ff8fd177452a7ed11dbb6efc7490ea WHIRLPOOL fbd3d94e47bb0aa2dfe6ce2aa9add5e3ed9b5abf84f39f142c093229628d3ea7ac9553c8fa4c555935aed71a4939ce76ba349d7ece58a4e34c81363381a923d7
diff --git a/media-libs/libsixel/libsixel-1.6.0.ebuild b/media-libs/libsixel/libsixel-1.6.0.ebuild
new file mode 100644
index 000000000000..2aa181387587
--- /dev/null
+++ b/media-libs/libsixel/libsixel-1.6.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit bash-completion-r1
+
+DESCRIPTION="A lightweight, fast implementation of DEC SIXEL graphics codec"
+HOMEPAGE="https://github.com/saitoha/libsixel"
+SRC_URI="https://github.com/saitoha/libsixel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="curl gd gtk jpeg png"
+
+RDEPEND="curl? ( net-misc/curl )
+ gd? ( media-libs/gd )
+ gtk? ( x11-libs/gdk-pixbuf:2 )
+ jpeg? ( virtual/jpeg:0 )
+ png? ( media-libs/libpng:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_with curl libcurl) \
+ $(use_with gd) \
+ $(use_with gtk gdk-pixbuf2) \
+ $(use_with jpeg) \
+ $(use_with png) \
+ --disable-python \
+ --with-bashcompletiondir=$(get_bashcompdir)
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ default
+
+ cd images
+ docompress -x /usr/share/doc/${PF}/images
+ docinto images
+ dodoc egret.jpg map{8,16}.png snake.jpg vimperator3.png
+}