summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-16 02:39:10 +0100
committerSam James <sam@gentoo.org>2022-08-16 02:39:10 +0100
commit477b7bfe0e87aa72022fc686fe8697d9923638ad (patch)
treede89064961e3c76cbbe627209e5d4fb03b9db11e /media-libs/libheif
parentmedia-libs/libheif: fix bashism in configure (diff)
downloadgentoo-477b7bfe0e87aa72022fc686fe8697d9923638ad.tar.gz
gentoo-477b7bfe0e87aa72022fc686fe8697d9923638ad.tar.bz2
gentoo-477b7bfe0e87aa72022fc686fe8697d9923638ad.zip
media-libs/libheif: unbundle catch
Not going to the hassle of fixing w/ 3 yet though. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/libheif')
-rw-r--r--media-libs/libheif/libheif-1.12.0-r3.ebuild12
-rw-r--r--media-libs/libheif/libheif-9999.ebuild12
2 files changed, 22 insertions, 2 deletions
diff --git a/media-libs/libheif/libheif-1.12.0-r3.ebuild b/media-libs/libheif/libheif-1.12.0-r3.ebuild
index 08b2005689dd..f6505de170a5 100644
--- a/media-libs/libheif/libheif-1.12.0-r3.ebuild
+++ b/media-libs/libheif/libheif-1.12.0-r3.ebuild
@@ -22,7 +22,12 @@ IUSE="+aom gdk-pixbuf go rav1e test +threads x265"
REQUIRED_USE="test? ( go )"
RESTRICT="!test? ( test )"
-BDEPEND="test? ( dev-lang/go )"
+BDEPEND="
+ test? (
+ <dev-cpp/catch-3
+ dev-lang/go
+ )
+"
DEPEND="
media-libs/dav1d:=[${MULTILIB_USEDEP}]
media-libs/libde265:=[${MULTILIB_USEDEP}]
@@ -46,6 +51,11 @@ src_prepare() {
sed -i -e 's:-Werror::' configure.ac || die
+ if use test ; then
+ rm tests/catch.hpp || die
+ ln -s "${ESYSROOT}"/usr/include/catch2/catch.hpp tests/catch.hpp || die
+ fi
+
eautoreconf
# prevent "stat heif-test.go: no such file or directory"
diff --git a/media-libs/libheif/libheif-9999.ebuild b/media-libs/libheif/libheif-9999.ebuild
index e7ee0500a762..457096c4b4e2 100644
--- a/media-libs/libheif/libheif-9999.ebuild
+++ b/media-libs/libheif/libheif-9999.ebuild
@@ -22,7 +22,12 @@ IUSE="+aom gdk-pixbuf go rav1e test +threads x265"
REQUIRED_USE="test? ( go )"
RESTRICT="!test? ( test )"
-BDEPEND="test? ( dev-lang/go )"
+BDEPEND="
+ test? (
+ <dev-cpp/catch-3
+ dev-lang/go
+ )
+"
DEPEND="
media-libs/dav1d:=[${MULTILIB_USEDEP}]
media-libs/libde265:=[${MULTILIB_USEDEP}]
@@ -45,6 +50,11 @@ src_prepare() {
sed -i -e 's:-Werror::' configure.ac || die
+ if use test ; then
+ rm tests/catch.hpp || die
+ ln -s "${ESYSROOT}"/usr/include/catch2/catch.hpp tests/catch.hpp || die
+ fi
+
eautoreconf
# prevent "stat heif-test.go: no such file or directory"