summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2024-11-25 16:37:49 +0100
committerSam James <sam@gentoo.org>2024-11-25 15:43:31 +0000
commitc93f43e52ce643fb120a663cd51545e48cf6aaf6 (patch)
tree9805a63c879c0afbeafc79d9ee7b4dd2b1ee7a67 /media-libs/lib3mf/lib3mf-2.2.0.ebuild
parentapp-editors/retext: drop 7.2.3, 8.0.0, 8.0.1, 8.0.1-r1 (diff)
downloadgentoo-c93f43e52ce643fb120a663cd51545e48cf6aaf6.tar.gz
gentoo-c93f43e52ce643fb120a663cd51545e48cf6aaf6.tar.bz2
gentoo-c93f43e52ce643fb120a663cd51545e48cf6aaf6.zip
media-libs/lib3mf: don't use bundled headers
The includes are hardcoded. This is fixed in newer releases, so instead of patching we just link the system includes to the place where they are expected. Closes: https://bugs.gentoo.org/944790 Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/lib3mf/lib3mf-2.2.0.ebuild')
-rw-r--r--media-libs/lib3mf/lib3mf-2.2.0.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/media-libs/lib3mf/lib3mf-2.2.0.ebuild b/media-libs/lib3mf/lib3mf-2.2.0.ebuild
deleted file mode 100644
index d5d470010791..000000000000
--- a/media-libs/lib3mf/lib3mf-2.2.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Implementation of the 3D Manufacturing Format file standard"
-HOMEPAGE="https://3mf.io/ https://github.com/3MFConsortium/lib3mf"
-SRC_URI="https://github.com/3MFConsortium/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/2"
-KEYWORDS="amd64 ~arm64 ~ppc64 x86"
-IUSE="+system-act test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/libzip:=
- sys-apps/util-linux
- sys-libs/zlib
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- system-act? ( dev-go/act )
- test? (
- dev-cpp/gtest
- dev-libs/openssl
- dev-debug/valgrind
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.1.0-0001-Gentoo-specific-avoid-pre-stripping-library.patch
- "${FILESDIR}"/${P}-0001-use-system-provided-act-binary.patch
- "${FILESDIR}"/${P}-0002-Gentoo-specific-remove-add_dependencies.patch
- "${FILESDIR}"/${P}-0001-remove-std-and-opt-flags.patch
- "${FILESDIR}"/${P}-include-cstdint.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_INSTALL_INCLUDEDIR="include/${PN}"
- -DLIB3MF_TESTS=$(usex test)
- -DUSE_INCLUDED_LIBZIP=OFF
- -DUSE_INCLUDED_ZLIB=OFF
- -DUSE_SYSTEM_ACT=$(usex system-act)
- )
-
- if use test; then
- mycmakeargs+=(
- -DUSE_INCLUDED_GTEST=OFF
- # code says it uses libressl, but works with openssl too
- -DUSE_INCLUDED_SSL=OFF
- )
- fi
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- for suf in abi types implicit; do
- dosym -r /usr/include/${PN}/Bindings/Cpp/${PN}_${suf}.hpp /usr/include/${PN}/${PN}_${suf}.hpp
- done
-}