summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-23 08:52:18 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-23 08:52:18 +0100
commit68900b6827e405826e9cc8d95fca2b74a8f2d244 (patch)
treed8d6d966fcb30c5aeda7f738b17237f4613d08e0 /media-libs/intel-mediasdk
parentmedia-libs/intel-mediasdk: add 22.6.5 (diff)
downloadgentoo-68900b6827e405826e9cc8d95fca2b74a8f2d244.tar.gz
gentoo-68900b6827e405826e9cc8d95fca2b74a8f2d244.tar.bz2
gentoo-68900b6827e405826e9cc8d95fca2b74a8f2d244.zip
media-libs/intel-mediasdk: drop 22.6.3, 22.6.4
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-libs/intel-mediasdk')
-rw-r--r--media-libs/intel-mediasdk/Manifest2
-rw-r--r--media-libs/intel-mediasdk/intel-mediasdk-22.6.3.ebuild82
-rw-r--r--media-libs/intel-mediasdk/intel-mediasdk-22.6.4.ebuild82
3 files changed, 0 insertions, 166 deletions
diff --git a/media-libs/intel-mediasdk/Manifest b/media-libs/intel-mediasdk/Manifest
index fbcec0525f4b..fbd85b044d4f 100644
--- a/media-libs/intel-mediasdk/Manifest
+++ b/media-libs/intel-mediasdk/Manifest
@@ -1,3 +1 @@
-DIST intel-mediasdk-22.6.3.tar.gz 11657130 BLAKE2B 3f63cf85716159f38f52cd0941cb716d9a25d2635e8b6da295a8fb78898ae007c3216148db580b94aa83742803effc0c1c2b0a431414a85f6feb44c93ae04738 SHA512 bd9fb9ca5b96bb2911db7fdf2622127f0dc3e86de8dc732bc6df6f4fcb343406e3ab14ffa5ce4595ed9b3bf19a73652681137fbe5b473c812c5b74554998a2b0
-DIST intel-mediasdk-22.6.4.tar.gz 11657778 BLAKE2B 3d95a685f5e4cc246367d046da8c8526264243321f0aacd2b9f6fbaed7eb0acdece1653801bd7cddd6b25338eecea6adb48b63a50049415621494cd481d455a1 SHA512 350347df8fd997a9043299faaee6fa6c8f67d3a301722c40ef8aab10bdfe6c01e7a2773c0add4617c98434e46030603ac56d4778074550498a128c7fb796c5a9
DIST intel-mediasdk-22.6.5.tar.gz 11657890 BLAKE2B 53b38f7b3757895f65badb7e43e5d1f1112f744dd4a43ea9313f7bfbdf889088310b2093ccd45794426f0ac5e38ca8d901790d4963945648a3b99922476d02e0 SHA512 af9a59a9a7e9477672a875f454988cc49d8b782b32701ba681efa6dda445239e133b00f9366fc58ddadf79beef0ee74f1165990f0b8194124a841b36d5dca6bc
diff --git a/media-libs/intel-mediasdk/intel-mediasdk-22.6.3.ebuild b/media-libs/intel-mediasdk/intel-mediasdk-22.6.3.ebuild
deleted file mode 100644
index a42d8290d2f3..000000000000
--- a/media-libs/intel-mediasdk/intel-mediasdk-22.6.3.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake optfeature
-
-if [[ ${PV} == *9999 ]] ; then
- : ${EGIT_REPO_URI:="https://github.com/Intel-Media-SDK/MediaSDK"}
- if [[ ${PV%9999} != "" ]] ; then
- : ${EGIT_BRANCH:="release/${PV%.9999}"}
- fi
- inherit git-r3
-fi
-
-DESCRIPTION="Intel Media SDK"
-HOMEPAGE="https://github.com/Intel-Media-SDK/MediaSDK"
-if [[ ${PV} == *9999 ]] ; then
- SRC_URI=""
-else
- SRC_URI="https://github.com/Intel-Media-SDK/MediaSDK/archive/intel-mediasdk-${PV}.tar.gz"
- S="${WORKDIR}/MediaSDK-intel-mediasdk-${PV}"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-IUSE="dri test +tools wayland X"
-# Test not working at the moment
-#RESTRICT="!test? ( test )"
-RESTRICT="test"
-# # Most of these flags only have an effect on the tools
-REQUIRED_USE="
- dri? ( X )
- wayland? ( tools )
- X? ( tools )
-"
-
-# x11-libs/libdrm[video_cards_intel] for intel_bufmgr.h in samples
-# bug #805224
-DEPEND="
- x11-libs/libpciaccess
- >=media-libs/libva-intel-media-driver-${PV}
- media-libs/libva[X?,wayland?]
- x11-libs/libdrm[video_cards_intel]
- wayland? (
- dev-libs/wayland
- dev-util/wayland-scanner
- dev-libs/wayland-protocols
- )
- X? (
- x11-libs/libX11
- x11-libs/libxcb
- )
-"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- # OpenCL only has an effect if we build kernels
- -DENABLE_OPENCL=OFF
- -DBUILD_TUTORIALS=OFF
- # Need to package the cm-compiler to build kernels, use pre-built instead
- -DBUILD_KERNELS=OFF
- -DBUILD_RUNTIME=ON
- -DBUILD_DISPATCHER=ON
- -DBUILD_TOOLS="$(usex tools)"
- # Cannot build tools without samples
- -DBUILD_SAMPLES="$(usex tools)"
- -DBUILD_TESTS="$(usex test)"
- -DENABLE_X11="$(usex X)"
- -DENABLE_X11_DRI3="$(usex dri)"
- -DENABLE_WAYLAND="$(usex wayland)"
- )
-
- cmake_src_configure
-}
-
-pkg_postinst() {
- optfeature "Intel GPUs newer then, and including, Intel Xe" media-libs/oneVPL-intel-gpu
-}
diff --git a/media-libs/intel-mediasdk/intel-mediasdk-22.6.4.ebuild b/media-libs/intel-mediasdk/intel-mediasdk-22.6.4.ebuild
deleted file mode 100644
index 27755b2b6e96..000000000000
--- a/media-libs/intel-mediasdk/intel-mediasdk-22.6.4.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake optfeature
-
-if [[ ${PV} == *9999 ]] ; then
- : ${EGIT_REPO_URI:="https://github.com/Intel-Media-SDK/MediaSDK"}
- if [[ ${PV%9999} != "" ]] ; then
- : ${EGIT_BRANCH:="release/${PV%.9999}"}
- fi
- inherit git-r3
-fi
-
-DESCRIPTION="Intel Media SDK"
-HOMEPAGE="https://github.com/Intel-Media-SDK/MediaSDK"
-if [[ ${PV} == *9999 ]] ; then
- SRC_URI=""
-else
- SRC_URI="https://github.com/Intel-Media-SDK/MediaSDK/archive/intel-mediasdk-${PV}.tar.gz"
- S="${WORKDIR}/MediaSDK-intel-mediasdk-${PV}"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-IUSE="dri test +tools wayland X"
-# Test not working at the moment
-#RESTRICT="!test? ( test )"
-RESTRICT="test"
-# Most of these flags only have an effect on the tools
-REQUIRED_USE="
- dri? ( X )
- wayland? ( tools )
- X? ( tools )
-"
-
-# x11-libs/libdrm[video_cards_intel] for intel_bufmgr.h in samples
-# bug #805224
-DEPEND="
- x11-libs/libpciaccess
- >=media-libs/libva-intel-media-driver-${PV}
- media-libs/libva[X?,wayland?]
- x11-libs/libdrm[video_cards_intel]
- wayland? (
- dev-libs/wayland
- dev-util/wayland-scanner
- dev-libs/wayland-protocols
- )
- X? (
- x11-libs/libX11
- x11-libs/libxcb
- )
-"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- # OpenCL only has an effect if we build kernels
- -DENABLE_OPENCL=OFF
- -DBUILD_TUTORIALS=OFF
- # Need to package the cm-compiler to build kernels, use pre-built instead
- -DBUILD_KERNELS=OFF
- -DBUILD_RUNTIME=ON
- -DBUILD_DISPATCHER=ON
- -DBUILD_TOOLS="$(usex tools)"
- # Cannot build tools without samples
- -DBUILD_SAMPLES="$(usex tools)"
- -DBUILD_TESTS="$(usex test)"
- -DENABLE_X11="$(usex X)"
- -DENABLE_X11_DRI3="$(usex dri)"
- -DENABLE_WAYLAND="$(usex wayland)"
- )
-
- cmake_src_configure
-}
-
-pkg_postinst() {
- optfeature "Intel GPUs newer then, and including, Intel Xe" media-libs/oneVPL-intel-gpu
-}