summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/fondu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/fondu')
-rw-r--r--media-gfx/fondu/Manifest1
-rw-r--r--media-gfx/fondu/files/fondu-20060102-build-fix.patch70
-rw-r--r--media-gfx/fondu/fondu-20060102-r1.ebuild33
-rw-r--r--media-gfx/fondu/metadata.xml5
4 files changed, 109 insertions, 0 deletions
diff --git a/media-gfx/fondu/Manifest b/media-gfx/fondu/Manifest
new file mode 100644
index 000000000000..7662b960d6e4
--- /dev/null
+++ b/media-gfx/fondu/Manifest
@@ -0,0 +1 @@
+DIST fondu_src-060102.tgz 131516 SHA256 22bb535d670ebc1766b602d804bebe7e84f907c219734e6a955fcbd414ce5794 SHA512 01d31901ab50eee70a74a3e211d78c55173748ad6e0cdadcda471a1f543856795a3bd8b421206cde044d240a1b425f32f6e40239ade0e87517e00b6ed9277bce WHIRLPOOL 26a39158cc4bda39f62c6dee9f6ab62fa9f5e0143924550e1bc806285e16755d6dd212b8c5b56c46bf7beb9a35019ab9171beb7d31d9887480a984b032d02d66
diff --git a/media-gfx/fondu/files/fondu-20060102-build-fix.patch b/media-gfx/fondu/files/fondu-20060102-build-fix.patch
new file mode 100644
index 000000000000..d84d0b7bde4e
--- /dev/null
+++ b/media-gfx/fondu/files/fondu-20060102-build-fix.patch
@@ -0,0 +1,70 @@
+Fixes:
+x86_64-pc-linux-gnu-gcc -O2 -c -o fondu.o fondu.c
+fondu.c: In function 'BuildFondList':
+fondu.c:515: error: called object 'strlen' is not a function
+
+x86_64-pc-linux-gnu-gcc -O2 -c -o frommacbinary.o frommacbinary.c
+frommacbinary.c: In function 'Usage':
+frommacbinary.c:58: warning: too few arguments for format
+
+Upstream: https://sourceforge.net/tracker/?func=detail&aid=2875547&group_id=39411&atid=425133
+Author: Peter Volkov <pva@gentoo.org>
+
+=== modified file 'fondu.c'
+--- fondu.c 2009-10-09 07:24:15 +0000
++++ fondu.c 2009-10-09 07:25:49 +0000
+@@ -473,7 +473,7 @@
+ }
+ if ( styleoff!=0 ) {
+ unsigned char stringoffsets[48];
+- int strcnt, strlen, format;
++ int strcnt, strlength, format;
+ char **strings, *pt;
+ fseek(f,styleoff,SEEK_SET);
+ /* class = */ getushort(f);
+@@ -484,11 +484,11 @@
+ strcnt = getushort(f);
+ strings = malloc(strcnt*sizeof(char *));
+ for ( j=0; j<strcnt; ++j ) {
+- strlen = getc(f);
+- strings[j] = malloc(strlen+2);
+- strings[j][0] = strlen;
+- strings[j][strlen+1] = '\0';
+- for ( k=0; k<strlen; ++k )
++ strlength = getc(f);
++ strings[j] = malloc(strlength+2);
++ strings[j][0] = strlength;
++ strings[j][strlength+1] = '\0';
++ for ( k=0; k<strlength; ++k )
+ strings[j][k+1] = getc(f);
+ }
+ for ( j=0; j<48; ++j ) {
+@@ -498,11 +498,11 @@
+ if ( k!=-1 || stringoffsets[j]==0 )
+ continue; /* this style doesn't exist */
+ format = stringoffsets[j]-1;
+- strlen = strings[0][0];
++ strlength = strings[0][0];
+ if ( format!=0 && format!=-1 )
+ for ( k=0; k<strings[format][0]; ++k )
+- strlen += strings[ strings[format][k+1]-1 ][0];
+- pt = cur->psnames[j] = malloc(strlen+1);
++ strlength += strings[ strings[format][k+1]-1 ][0];
++ pt = cur->psnames[j] = malloc(strlength+1);
+ strcpy(pt,strings[ 0 ]+1);
+ pt += strings[ 0 ][0];
+ if ( format!=0 && format!=-1 )
+
+=== modified file 'frommacbinary.c'
+--- frommacbinary.c 2009-10-09 07:24:15 +0000
++++ frommacbinary.c 2009-10-09 07:27:54 +0000
+@@ -55,7 +55,7 @@
+ /* frombin filenames */
+
+ static void Usage(char *prog) {
+- fprintf( stderr, "Usage: %s [-usage] [-help] [-version] filenames\n" );
++ fprintf( stderr, "Usage: frombin [-usage] [-help] [-version] filenames\n" );
+ fprintf( stderr, " -usage\t\tPrints this message\n" );
+ fprintf( stderr, " -help\t\tPrints this message\n" );
+ fprintf( stderr, " -version\t\tPrints the version of the program\n" );
+
diff --git a/media-gfx/fondu/fondu-20060102-r1.ebuild b/media-gfx/fondu/fondu-20060102-r1.ebuild
new file mode 100644
index 000000000000..27d34db99f11
--- /dev/null
+++ b/media-gfx/fondu/fondu-20060102-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+MY_PV=${PV:2:6}
+
+DESCRIPTION="Utilities for converting between and manipulating mac fonts and unix fonts"
+HOMEPAGE="http://fondu.sourceforge.net/"
+SRC_URI="http://fondu.sourceforge.net/${PN}_src-${MY_PV}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE=""
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_prepare() {
+ sed -e 's:^CFLAGS =:CFLAGS +=:' \
+ -e 's:$(CFLAGS) -o:$(CFLAGS) $(LDFLAGS) -o:' \
+ -e 's:wilprefix:prefix:' \
+ -i Makefile.in || die "failed to sed"
+ epatch "${FILESDIR}/${P}-build-fix.patch"
+}
+
+src_install() {
+ default
+ doman *.1
+}
diff --git a/media-gfx/fondu/metadata.xml b/media-gfx/fondu/metadata.xml
new file mode 100644
index 000000000000..696065edd338
--- /dev/null
+++ b/media-gfx/fondu/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>fonts</herd>
+</pkgmetadata>