summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-08-17 16:39:00 +0200
committerEli Schwartz <eschwartz@gentoo.org>2024-08-21 20:31:44 -0400
commitfa86e10f046d749775cc5957d9bac8d9c800d95c (patch)
tree70b74963de2a98389ae4628a2190c8b353daa1e2 /media-fonts/source-code-pro
parentmedia-libs/jasper: add 4.2.4 (diff)
downloadgentoo-fa86e10f046d749775cc5957d9bac8d9c800d95c.tar.gz
gentoo-fa86e10f046d749775cc5957d9bac8d9c800d95c.tar.bz2
gentoo-fa86e10f046d749775cc5957d9bac8d9c800d95c.zip
media-fonts/source-code-pro: add 2.042
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/38180 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'media-fonts/source-code-pro')
-rw-r--r--media-fonts/source-code-pro/Manifest1
-rw-r--r--media-fonts/source-code-pro/source-code-pro-2.042.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/media-fonts/source-code-pro/Manifest b/media-fonts/source-code-pro/Manifest
index f0c144e08fd9..c585dfb89c1d 100644
--- a/media-fonts/source-code-pro/Manifest
+++ b/media-fonts/source-code-pro/Manifest
@@ -1 +1,2 @@
DIST source-code-pro-2.038.tar.gz 6818951 BLAKE2B b133aa317bf5057e8b346d81491bf08c0c257066ed05b2001a9e327308a63a3ef943da3b12b5933c217c31839750fbb3947b4f566f48aac6e88c7096cbbf82cd SHA512 96981af2a470027a372ab8a02265d34a6b2a810c4cca0b498b01e613019a04c9760d95e21fb740af2c7fff076098bb36f5c282bf9b8f1875eed72ed70e4b3ac9
+DIST source-code-pro-2.042.tar.gz 8148876 BLAKE2B 16d5097bb8adbdbf0c0c61f708ea460e7608ebde7921fed464a2b71ed159416d9920bcbd72ad63d47a89460426a5c5af0c5a19ebac00ee7a1db0d61ae77a9823 SHA512 2cc2373c8f5ec817ee44e2c754735a4d21d989fd581bf1cdb764ba98a26b186574d7f583ebe0da905c4db029d12fd4df54ace43a191e274f76995940a618a91c
diff --git a/media-fonts/source-code-pro/source-code-pro-2.042.ebuild b/media-fonts/source-code-pro/source-code-pro-2.042.ebuild
new file mode 100644
index 000000000000..aa6e0b741041
--- /dev/null
+++ b/media-fonts/source-code-pro/source-code-pro-2.042.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit font optfeature
+
+REALV="2.042R-u/1.062R-i/1.026R-vf"
+
+DESCRIPTION="Monospaced font family for user interface and coding environments"
+HOMEPAGE="https://adobe-fonts.github.io/source-code-pro/"
+SRC_URI="https://github.com/adobe-fonts/source-code-pro/archive/${REALV}.tar.gz -> source-code-pro-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${REALV//\//-}"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RESTRICT="binchecks strip"
+
+RDEPEND="
+ media-libs/fontconfig
+"
+
+FONT_CONF=( "${FILESDIR}"/63-${PN}.conf )
+FONT_SUFFIX="otf"
+
+src_prepare() {
+ default
+ mv OTF/*.otf . || die
+}
+
+pkg_postinst() {
+ optfeature_header "Other variants of this font are:"
+ optfeature "Chinese, Japanese and Korean support" media-fonts/source-han-sans
+ optfeature "the sans-serif variant" media-fonts/source-sans
+ optfeature "the serif variant" media-fonts/source-serif
+}