summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-04-16 21:11:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-04-16 21:50:25 +0200
commit8b17ae50a863cf9106c8d75a276a3425f3bc522c (patch)
treeef2facd423f54dd5b5c79037ba0dff8e38771abd /kde-plasma/kwayland-integration
parentkde-plasma/kwallet-pam: add 6.0.4 (diff)
downloadgentoo-8b17ae50a863cf9106c8d75a276a3425f3bc522c.tar.gz
gentoo-8b17ae50a863cf9106c8d75a276a3425f3bc522c.tar.bz2
gentoo-8b17ae50a863cf9106c8d75a276a3425f3bc522c.zip
kde-plasma/kwayland-integration: add 6.0.4
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwayland-integration')
-rw-r--r--kde-plasma/kwayland-integration/Manifest1
-rw-r--r--kde-plasma/kwayland-integration/kwayland-integration-6.0.4.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-integration/Manifest b/kde-plasma/kwayland-integration/Manifest
index 6ae96b0666e3..ee2cd28d16b0 100644
--- a/kde-plasma/kwayland-integration/Manifest
+++ b/kde-plasma/kwayland-integration/Manifest
@@ -1,2 +1,3 @@
DIST kwayland-integration-5.27.11.tar.xz 25708 BLAKE2B 67fe2d113955b2cdec1c3d621efbe84b2565aa3f22e0d15eb95f1a2bce1a6c7fe87da9c2974d93fb2f1939d92d64d2ab2a2a1db609df5973ded5ac4a02f214cf SHA512 c5f19a03e8161b346dbd89fb0d1b72d7906c19a7d55535878d9d75b7d96025d61808161f6b0ccaf9b5fef1d112f8e0ba1033ce149e42aec2cd261351d5ffb1c9
DIST kwayland-integration-6.0.3.tar.xz 26400 BLAKE2B ebeae70e81c5eb3f7f084fe099befd3dc8b99042d2b984f9bf16a9b36f212c55ded00e8a49a78fbc44a9d83df9c94eba733340fd80908e88f419aee13079d751 SHA512 0caf516444afb9fa5b148461f1301fb865c691ad39f120c3919194be643492721210a2c1a584f8bcacef9ad2fd2f04a563eb18e3b388bb4322574fd0f2d590af
+DIST kwayland-integration-6.0.4.tar.xz 26392 BLAKE2B 774a60343555fc480b98700886abc0769bcd25f996070603cdfd2735ff0dabb1e913e2901ee93eaad0dd4de31b48d871b2da59d15805bce920eec9af79f63179 SHA512 2fac1bf44212a0c70f89625bdf7169551e26d252299e740a3c0ee4c87a3172ed69549856c7cc0f2cb27b09c5b72fe4de14a186e2d513436708d839e95503157a
diff --git a/kde-plasma/kwayland-integration/kwayland-integration-6.0.4.ebuild b/kde-plasma/kwayland-integration/kwayland-integration-6.0.4.ebuild
new file mode 100644
index 000000000000..2ce54ec08c7a
--- /dev/null
+++ b/kde-plasma/kwayland-integration/kwayland-integration-6.0.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.115.0
+QTMIN=5.15.12
+inherit ecm flag-o-matic plasma.kde.org
+
+DESCRIPTION="Provides KWindowSystem integration plugin for Wayland"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-integration"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot ops:
+# dev-qt/qtgui: QtXkbCommonSupportPrivate
+# dev-qt/qtwayland: Qt::WaylandClientPrivate (private/qwayland*_p.h) stuff
+# kde-frameworks/kwindowsystem: Various private headers
+RDEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtgui-${QTMIN}:5=
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=
+ >=kde-plasma/kwayland-${KFMIN}:5
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}
+ dev-libs/plasma-wayland-protocols
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ filter-lto # bug 921430
+ ecm_src_configure
+}