summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-07-09 13:26:07 +0200
committerJohannes Huber <johu@gentoo.org>2016-07-09 13:26:18 +0200
commit1efcf4a75fe009c2eac7b89c42e2b4b4b162834a (patch)
treea9d6dc56e66a8df4621208a6176b8ce8fd6f2b8a /kde-frameworks/sonnet/sonnet-5.24.0.ebuild
parentgnome-extra/cinnamon: Rebuilding with NM subslot bump will be needed when it'... (diff)
downloadgentoo-1efcf4a75fe009c2eac7b89c42e2b4b4b162834a.tar.gz
gentoo-1efcf4a75fe009c2eac7b89c42e2b4b4b162834a.tar.bz2
gentoo-1efcf4a75fe009c2eac7b89c42e2b4b4b162834a.zip
kde-frameworks: Version bump KDE Frameworks 5.24.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-frameworks/sonnet/sonnet-5.24.0.ebuild')
-rw-r--r--kde-frameworks/sonnet/sonnet-5.24.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/sonnet-5.24.0.ebuild b/kde-frameworks/sonnet/sonnet-5.24.0.ebuild
new file mode 100644
index 000000000000..43f93ea5b05b
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.24.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="aspell +hunspell nls"
+
+RDEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package aspell ASPELL)
+ $(cmake-utils_use_find_package hunspell HUNSPELL)
+ )
+
+ kde5_src_configure
+}