summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-21 16:25:37 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-21 16:26:02 +0200
commit3d4d8bd733a6b80b7ea836e959f56245898568cc (patch)
treedefe627d041f349b8e5d9df8e35363ebd78f73fd /kde-apps/kwave
parentapp-office/libreoffice: Fix configure.ac bashism (diff)
downloadgentoo-3d4d8bd733a6b80b7ea836e959f56245898568cc.tar.gz
gentoo-3d4d8bd733a6b80b7ea836e959f56245898568cc.tar.bz2
gentoo-3d4d8bd733a6b80b7ea836e959f56245898568cc.zip
kde-apps/kwave: Fix build with GCC-11
Closes: https://bugs.gentoo.org/790158 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kwave')
-rw-r--r--kde-apps/kwave/files/kwave-21.04.1-gcc11.patch12
-rw-r--r--kde-apps/kwave/kwave-21.04.1.ebuild2
2 files changed, 14 insertions, 0 deletions
diff --git a/kde-apps/kwave/files/kwave-21.04.1-gcc11.patch b/kde-apps/kwave/files/kwave-21.04.1-gcc11.patch
new file mode 100644
index 000000000000..cc2e8218cf1b
--- /dev/null
+++ b/kde-apps/kwave/files/kwave-21.04.1-gcc11.patch
@@ -0,0 +1,12 @@
+diff --git a/plugins/codec_wav/WavDecoder.cpp b/plugins/codec_wav/WavDecoder.cpp
+index 9430404..2390c08 100644
+--- a/plugins/codec_wav/WavDecoder.cpp
++++ b/plugins/codec_wav/WavDecoder.cpp
+@@ -18,6 +18,7 @@
+ #include "config.h"
+ #include <stdlib.h>
+ #include <new>
++#include <limits>
+
+ #include <audiofile.h>
+
diff --git a/kde-apps/kwave/kwave-21.04.1.ebuild b/kde-apps/kwave/kwave-21.04.1.ebuild
index d8dc219b5841..9da914a5b6e7 100644
--- a/kde-apps/kwave/kwave-21.04.1.ebuild
+++ b/kde-apps/kwave/kwave-21.04.1.ebuild
@@ -69,6 +69,8 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS CHANGES LICENSES README TODO )
+PATCHES=( "${FILESDIR}/${P}-gcc11.patch" ) # bug 790158, KDE-bug 437432; pending
+
src_configure() {
local mycmakeargs=(
-DDEBUG=$(usex debug)