summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-16 06:20:22 +0100
committerSam James <sam@gentoo.org>2023-04-16 06:26:01 +0100
commit67dd4fbd591c399f461f63d61a6012d7bf7e6237 (patch)
tree8ea869a49ba65fd8180eb5077578937db29cc912 /dev-util
parentmedia-sound/abcmidi: dropped obsolete 2023.02.08 (diff)
downloadgentoo-67dd4fbd591c399f461f63d61a6012d7bf7e6237.tar.gz
gentoo-67dd4fbd591c399f461f63d61a6012d7bf7e6237.tar.bz2
gentoo-67dd4fbd591c399f461f63d61a6012d7bf7e6237.zip
dev-util/bear: fix tests w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bear/bear-3.0.21.ebuild4
-rw-r--r--dev-util/bear/files/bear-3.0.21-clang16-tests.patch32
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/bear/bear-3.0.21.ebuild b/dev-util/bear/bear-3.0.21.ebuild
index 14481878c2f2..6b0aff0cffe9 100644
--- a/dev-util/bear/bear-3.0.21.ebuild
+++ b/dev-util/bear/bear-3.0.21.ebuild
@@ -45,6 +45,10 @@ RESTRICT="!test? ( test )"
S="${WORKDIR}/${P^}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.21-clang16-tests.patch
+)
+
pkg_setup() {
use test && python-any-r1_pkg_setup
}
diff --git a/dev-util/bear/files/bear-3.0.21-clang16-tests.patch b/dev-util/bear/files/bear-3.0.21-clang16-tests.patch
new file mode 100644
index 000000000000..19c63ba60849
--- /dev/null
+++ b/dev-util/bear/files/bear-3.0.21-clang16-tests.patch
@@ -0,0 +1,32 @@
+https://github.com/rizsotto/Bear/pull/521
+
+From 472cbed312444cdcef9102e924c79070ea1d3ab2 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Sat, 15 Apr 2023 19:37:41 +0200
+Subject: [PATCH] Avoid implicit function declarations in tests, for C99
+ compatibility
+
+Include <stdio.h> for printf and define _GNU_SOURCE for execvpe.
+
+Future compilers will not support implicit function declartions by
+default, causing these tests to fail to build.
+--- a/test/cases/intercept/preload/errno_reset.c
++++ b/test/cases/intercept/preload/errno_reset.c
+@@ -5,6 +5,7 @@
+ #include <stdlib.h>
+ #include <errno.h>
+ #include <string.h>
++#include <stdio.h>
+
+ int main()
+ {
+--- a/test/cases/intercept/preload/posix/execvpe/success.c
++++ b/test/cases/intercept/preload/posix/execvpe/success.c
+@@ -8,6 +8,7 @@
+ #include "config.h"
+
+ #if defined HAVE_UNISTD_H
++#define _GNU_SOURCE
+ #include <unistd.h>
+ #endif
+