summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-15 10:08:53 +0100
committerSam James <sam@gentoo.org>2023-04-15 10:32:28 +0100
commit4455b9916ad120361e1587d44f77bf93886d2c6a (patch)
treee3441c69372a77f864bbb96fdfdf5b3550190551 /dev-util
parentnet-analyzer/tcpflow: fix build w/ gcc 13 (diff)
downloadgentoo-4455b9916ad120361e1587d44f77bf93886d2c6a.tar.gz
gentoo-4455b9916ad120361e1587d44f77bf93886d2c6a.tar.bz2
gentoo-4455b9916ad120361e1587d44f77bf93886d2c6a.zip
dev-util/edb-debugger: fix build w/ gcc 13
Closes: https://bugs.gentoo.org/897890 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/edb-debugger/edb-debugger-1.3.0-r1.ebuild3
-rw-r--r--dev-util/edb-debugger/files/edb-debugger-1.3.0-gcc13.patch26
2 files changed, 28 insertions, 1 deletions
diff --git a/dev-util/edb-debugger/edb-debugger-1.3.0-r1.ebuild b/dev-util/edb-debugger/edb-debugger-1.3.0-r1.ebuild
index 01f72a1e8911..1e01b9496797 100644
--- a/dev-util/edb-debugger/edb-debugger-1.3.0-r1.ebuild
+++ b/dev-util/edb-debugger/edb-debugger-1.3.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -40,6 +40,7 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${P}-gcc12.patch
"${FILESDIR}"/${PN}-1.3.0-capstone-5.patch
+ "${FILESDIR}"/${PN}-1.3.0-gcc13.patch
)
src_prepare() {
diff --git a/dev-util/edb-debugger/files/edb-debugger-1.3.0-gcc13.patch b/dev-util/edb-debugger/files/edb-debugger-1.3.0-gcc13.patch
new file mode 100644
index 000000000000..f30eacc97436
--- /dev/null
+++ b/dev-util/edb-debugger/files/edb-debugger-1.3.0-gcc13.patch
@@ -0,0 +1,26 @@
+https://github.com/eteran/edb-debugger/pull/837
+
+From 934de81a7799f3e1d210366e0eb5ea86d172ead4 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sat, 15 Apr 2023 10:05:11 +0100
+Subject: [PATCH] Fix build with GCC 13
+
+GCC 13 (as usual for new compiler releases) shuffles around some internal includes so some
+are no longer transitively included.
+
+See https://gnu.org/software/gcc/gcc-13/porting_to.html.
+
+Bug: https://bugs.gentoo.org/897890
+--- a/plugins/DebuggerCore/unix/linux/FeatureDetect.cpp
++++ b/plugins/DebuggerCore/unix/linux/FeatureDetect.cpp
+@@ -19,6 +19,7 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
+ #include "FeatureDetect.h"
+ #include "edb.h"
+
++#include <cstdint>
+ #include <fcntl.h>
+ #include <iomanip>
+ #include <iostream>
+--
+2.40.0
+