summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-07 17:23:29 +0000
committerSam James <sam@gentoo.org>2024-01-07 17:23:48 +0000
commit34cf0a8d2ab1c37cbe725117a8e3edc565b1ef1c (patch)
treed910789b62c0d251759d3b1a2a9b2a9c6eda1415 /dev-util/umockdev
parentsys-apps/memtest86+: rename USE=efi* to USE=uefi* (diff)
downloadgentoo-34cf0a8d2ab1c37cbe725117a8e3edc565b1ef1c.tar.gz
gentoo-34cf0a8d2ab1c37cbe725117a8e3edc565b1ef1c.tar.bz2
gentoo-34cf0a8d2ab1c37cbe725117a8e3edc565b1ef1c.zip
dev-util/umockdev: drop -Werror=unused-variable (for Vala)
Exposed by a change in Meson to stop inhibiting Vala warnings, e.g. ``` umockdev-record.p/src/umockdev-pcap.c: At top level: umockdev-record.p/src/umockdev-pcap.c:101:20: error: ‘umockdev_ioctl_usb_pcap_handler_properties’ defined but not used [-Werror=unused-variable] 101 | static GParamSpec* umockdev_ioctl_usb_pcap_handler_properties[UMOCKDEV_IOCTL_USB_PCAP_HANDLER_NUM_PROPERTIES]; | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ``` See https://github.com/mesonbuild/meson/commit/5f659af870011e74299d1455a65c2cd5f5ace51f. Closes: https://bugs.gentoo.org/919380 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/umockdev')
-rw-r--r--dev-util/umockdev/files/umockdev-0.17.18-vala-unused-variable-werror.patch22
-rw-r--r--dev-util/umockdev/umockdev-0.17.18.ebuild6
2 files changed, 27 insertions, 1 deletions
diff --git a/dev-util/umockdev/files/umockdev-0.17.18-vala-unused-variable-werror.patch b/dev-util/umockdev/files/umockdev-0.17.18-vala-unused-variable-werror.patch
new file mode 100644
index 000000000000..69023f08e5e2
--- /dev/null
+++ b/dev-util/umockdev/files/umockdev-0.17.18-vala-unused-variable-werror.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/919380
+
+Exposed by a change in Meson to stop inhibiting Vala warnings, e.g.
+```
+umockdev-record.p/src/umockdev-pcap.c: At top level:
+umockdev-record.p/src/umockdev-pcap.c:101:20: error: ‘umockdev_ioctl_usb_pcap_handler_properties’ defined but not used [-Werror=unused-variable]
+ 101 | static GParamSpec* umockdev_ioctl_usb_pcap_handler_properties[UMOCKDEV_IOCTL_USB_PCAP_HANDLER_NUM_PROPERTIES];
+ | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+```
+
+See https://github.com/mesonbuild/meson/commit/5f659af870011e74299d1455a65c2cd5f5ace51f.
+--- a/meson.build
++++ b/meson.build
+@@ -21,7 +21,7 @@ add_project_arguments(
+ '-Werror=format-security',
+ '-Werror=format=2',
+ #'-Werror=missing-include-dirs',
+- '-Werror=unused-variable',
++ #'-Werror=unused-variable',
+ '-Werror=return-type',
+ '-Werror=uninitialized',
+ # experimental: first check this on all Debian architectures
diff --git a/dev-util/umockdev/umockdev-0.17.18.ebuild b/dev-util/umockdev/umockdev-0.17.18.ebuild
index d195c94f4c13..b627c3aa9f25 100644
--- a/dev-util/umockdev/umockdev-0.17.18.ebuild
+++ b/dev-util/umockdev/umockdev-0.17.18.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -40,6 +40,10 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.17.18-vala-unused-variable-werror.patch
+)
+
pkg_setup() {
use test && python-any-r1_pkg_setup
}