summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-08-25 10:07:06 +0200
committerHans de Graaff <graaff@gentoo.org>2024-08-25 10:10:00 +0200
commitd818ef2f1ae5da51d652261a300e6435d175b07c (patch)
treee053c78bb51ab08df1328f7664ef5f94d74ea25e /dev-ruby
parentnet-print/epson-inkjet-printer-escpr: remove debug message from global scope (diff)
downloadgentoo-d818ef2f1ae5da51d652261a300e6435d175b07c.tar.gz
gentoo-d818ef2f1ae5da51d652261a300e6435d175b07c.tar.bz2
gentoo-d818ef2f1ae5da51d652261a300e6435d175b07c.zip
dev-ruby/actionview: fix tests with ruby31, ruby32
Avoid tests that require the unpackaged prism parser. Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionview/actionview-7.2.1.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/dev-ruby/actionview/actionview-7.2.1.ebuild b/dev-ruby/actionview/actionview-7.2.1.ebuild
index 11e0b65d9f0e..8ff948034e09 100644
--- a/dev-ruby/actionview/actionview-7.2.1.ebuild
+++ b/dev-ruby/actionview/actionview-7.2.1.ebuild
@@ -74,3 +74,14 @@ all_ruby_prepare() {
sed -e '/test_sanitized_allowed_\(tags_class_method\|attributes_class_method\)/askip "Removed upstream"' \
-i test/template/sanitize_helper_test.rb || die
}
+
+each_ruby_prepare() {
+ # The new prism parser is currently unpackaged and only included with ruby33.
+ case ${RUBY} in
+ *ruby31|*ruby32)
+ sed -e '/prism/ s:^:#:' \
+ -e '/PrismRubyTrackerTest/,/^end/ s:^:#:' \
+ -i test/template/dependency_tracker_test.rb || die
+ ;;
+ esac
+}