summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-02-29 13:35:51 +0100
committerHans de Graaff <graaff@gentoo.org>2024-02-29 13:36:02 +0100
commit11d04944607caa8a7a4465b87b1159ffa180bb7c (patch)
treedc513030abea447daa986a7272923f795244e4ba /dev-ruby/yard
parentdev-ruby/thor: add 1.3.1 (diff)
downloadgentoo-11d04944607caa8a7a4465b87b1159ffa180bb7c.tar.gz
gentoo-11d04944607caa8a7a4465b87b1159ffa180bb7c.tar.bz2
gentoo-11d04944607caa8a7a4465b87b1159ffa180bb7c.zip
dev-ruby/yard: add 0.9.35
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/yard')
-rw-r--r--dev-ruby/yard/Manifest2
-rw-r--r--dev-ruby/yard/yard-0.9.35.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-ruby/yard/Manifest b/dev-ruby/yard/Manifest
index 0c159ee5ea53..2ef65ca6b2ec 100644
--- a/dev-ruby/yard/Manifest
+++ b/dev-ruby/yard/Manifest
@@ -2,3 +2,5 @@ DIST yard-0.9.28-git.tgz 932436 BLAKE2B 7340f6815698ddb85aa16752266af75ecd3e1f1a
DIST yard-0.9.34-bom-encoding.patch 1045 BLAKE2B be4ac8c52c27b916f83d87334c64427e19a831b4b81dc926db4963c651df5106b7d63a8ecd3cdf9889d023bb8f43134c00a1db0c3f10578997e6abf94d3c08fa SHA512 6af3f7c80a0044c1b14b61bff6c0e539a8512956cea8ceb9dbe84d38e1072f49c7119d95f4313af5a054f6462eb330b66dec55c199db92c1b16fcb89c6ebc482
DIST yard-0.9.34-git.tgz 938057 BLAKE2B 0e5b96b29efc6b7ab6c52dc34a15d4df9b614eb56698eb76fc7d2dc1f1fcfa5f8883034697f5a3fbd76ff588a9ebf2c7ee164936809bfe4640663c996e9f648a SHA512 fb87e3706d2c1408a172e17cdb588aacb2c67b9e7ac8c9b2d2a4d2e8a67a0c571d05938f8a4a88357834f6dac13a38cf1faa086680d58380a65cc2fca93aad8f
DIST yard-0.9.34-yield-ruby33.patch 920 BLAKE2B a0492919b8038c21c109732aa12afa4d494ceacf6ff5e2c8fbae56bc279b5e9c6a951f77144d069183d7dc9ad818066aab5c4d82c4dc39c31a48272dad6a0d0b SHA512 86bd7d2b8ccfccc73a46365b0814c0d741bde8508317856d80ae6a2cccff1a338ad9754afd21f8f64d2587195f8cc3f38b6eba78e8de1d729ac3b2141bdb124a
+DIST yard-0.9.35-git.tgz 938495 BLAKE2B 27e8c0e576f5150d1adcfd63afdfcb33f437319ae646347c8b0ab24e6b093b4d3de3f0703cc0683a420e93f8d6261c2221d0af7c3ed6dfe463d2f296bdfeda49 SHA512 83251d52b8f4ec00411cb223386b9b3763da530c37db7a99a9a3747139b97f52d4e978e7556c3d50896537ad60a89d88b67affc630d4f7617062c33e6ec223ac
+DIST yard-0.9.35-yield-ruby33.patch 920 BLAKE2B a0492919b8038c21c109732aa12afa4d494ceacf6ff5e2c8fbae56bc279b5e9c6a951f77144d069183d7dc9ad818066aab5c4d82c4dc39c31a48272dad6a0d0b SHA512 86bd7d2b8ccfccc73a46365b0814c0d741bde8508317856d80ae6a2cccff1a338ad9754afd21f8f64d2587195f8cc3f38b6eba78e8de1d729ac3b2141bdb124a
diff --git a/dev-ruby/yard/yard-0.9.35.ebuild b/dev-ruby/yard/yard-0.9.35.ebuild
new file mode 100644
index 000000000000..00b9321f3642
--- /dev/null
+++ b/dev-ruby/yard/yard-0.9.35.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_DOCDIR="doc docs"
+
+RUBY_FAKEGEM_EXTRAINSTALL="templates .yardopts"
+
+RUBY_FAKEGEM_GEMSPEC="yard.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Documentation generation tool for the Ruby programming language"
+HOMEPAGE="https://yardoc.org/"
+
+# The gem lacks the gemspec file needed to pass tests.
+SRC_URI="https://github.com/lsegal/yard/archive/v${PV}.tar.gz -> ${P}-git.tgz
+ https://github.com/lsegal/yard/commit/d840ee127dfd79abd208a155f01d66293ae290ca.patch -> ${P}-yield-ruby33.patch"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.34-beginless-range.patch"
+ "${DISTDIR}/${P}-yield-ruby33.patch"
+)
+
+ruby_add_bdepend "doc? ( || ( dev-ruby/maruku dev-ruby/rdiscount dev-ruby/kramdown ) )"
+
+ruby_add_bdepend "test? ( dev-ruby/rack:2.2 >=dev-ruby/rspec-3.11.0 dev-ruby/webrick )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '3igem "rack", "~> 2.2.0"' spec/spec_helper.rb || die
+
+ sed -i -e '/samus/I s:^:#:' Rakefile || die
+
+ sed -i -e 's/git ls-files/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid specs that make assumptions on load ordering that are not
+ # true for us. This may be related to how we install in Gentoo. This
+ # also drops a test requirement on dev-ruby/rack.
+ rm -f spec/cli/server_spec.rb || die
+
+ # Avoid specs that only work with bundler
+ sed -i -e '/#initialize/,/^ end/ s:^:#:' spec/cli/yri_spec.rb || die
+ sed -e '/overwrites options with data in/askip "wrong assumptions on file access"' \
+ -e '/loads any gem plugins starting with/askip "wrong assumptions on file access"' \
+ -i spec/config_spec.rb || die
+
+ # Avoid specs making assumptions about how rubygems works internally
+ sed -i -e '/searches for .gem file/askip "rubygems internals"' spec/cli/diff_spec.rb || die
+
+ # Fix broken spec
+ sed -i -e '/:exist?/aallow(File).to receive(:exist?).and_call_original' spec/i18n/locale_spec.rb || die
+
+ # Avoid ruby31 failure on whitespace-only differences
+ sed -i -e '/shows a list of nodes/askip "Whitespace differences on ruby31"' spec/parser/ruby/ast_node_spec.rb || die
+
+ # Avoid redcarpet-specific spec that is not optional
+ sed -i -e '/autolinks URLs/askip "make redcarpet optional"' spec/templates/helpers/html_helper_spec.rb || die
+
+ # Avoid asciidoc-specific spec that is not optional
+ sed -e '/\(AsciiDoc specific\|AsciiDoc header\)/askip "skipping asciidoc test"' \
+ -i spec/templates/helpers/html_helper_spec.rb || die
+}