summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-02 04:03:42 +0100
committerSam James <sam@gentoo.org>2023-04-02 06:06:19 +0100
commit0db4ac351489627496f1c432d1f9d5d5323c62c1 (patch)
tree959a8ebe0b0d02be97296b7fd76d90b254ef8a0f /dev-ruby/thor
parentapp-i18n/ibus-typing-booster: new upstream release (diff)
downloadgentoo-0db4ac351489627496f1c432d1f9d5d5323c62c1.tar.gz
gentoo-0db4ac351489627496f1c432d1f9d5d5323c62c1.tar.bz2
gentoo-0db4ac351489627496f1c432d1f9d5d5323c62c1.zip
dev-ruby/thor: cleanup ruby27-only USE_RUBY for tests
We have a hack in dev-ruby/thor to avoid too many test dependencies when porting to a newer Ruby, which is fine (we do it for Python all the time too), but in this case, it only contains now-removed (or about to be removed) Rubies. After 92902571781915a800816c1a89e68c3d1b9cad94, this is no longer ignored when we try to cleanup/mask/disable old Rubies. Upon reflection, I think this is the right behaviour: 1. If real runtime dependencies are only needed for older Rubies then we want to clean up the condition once it's useless, not ignore it; 2. If test conditions are only used for old rubies, we either want to clean it up (because it's obsolete) or fix it (if we left a trick behind when bootstrapping a new Ruby, as it means we're not testing it). While at it, add a comment explaining what we're doing, as it's a useful thing to know about. Bonus: in this case, it was obscuring a real issue - we weren't running tests for >=ruby30 long after ruby30 got added and we missed that the hash tests failed. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/thor')
-rw-r--r--dev-ruby/thor/thor-1.2.1-r1.ebuild4
-rw-r--r--dev-ruby/thor/thor-1.2.1.ebuild9
2 files changed, 11 insertions, 2 deletions
diff --git a/dev-ruby/thor/thor-1.2.1-r1.ebuild b/dev-ruby/thor/thor-1.2.1-r1.ebuild
index c37062054e0e..08ba908ee3ce 100644
--- a/dev-ruby/thor/thor-1.2.1-r1.ebuild
+++ b/dev-ruby/thor/thor-1.2.1-r1.ebuild
@@ -23,6 +23,10 @@ SLOT="$(ver_cut 1)"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux"
IUSE="doc"
+# For initial target porting (new rubies), we can make these test deps
+# conditional with:
+# 1. USE_RUBY="<old rubies>" ruby_add_bdepend ...
+# 2. skip logic in each_ruby_test
USE_RUBY="ruby27 ruby30 ruby31" ruby_add_bdepend "
test? (
dev-ruby/childlabor
diff --git a/dev-ruby/thor/thor-1.2.1.ebuild b/dev-ruby/thor/thor-1.2.1.ebuild
index e6d6b567ebcb..833e26c3ca37 100644
--- a/dev-ruby/thor/thor-1.2.1.ebuild
+++ b/dev-ruby/thor/thor-1.2.1.ebuild
@@ -23,11 +23,16 @@ SLOT="$(ver_cut 1)"
KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux"
IUSE="doc"
-USE_RUBY="ruby26 ruby27" ruby_add_bdepend "
+# For initial target porting (new rubies), we can make these test deps
+# conditional with:
+# 1. USE_RUBY="<old rubies>" ruby_add_bdepend ...
+# 2. skip logic in each_ruby_test
+ruby_add_bdepend "
test? (
dev-ruby/childlabor
dev-ruby/webmock
- )"
+ )
+"
RDEPEND+=" !<dev-ruby/thor-0.20.3-r1:0"