summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-07-05 06:59:14 +0200
committerHans de Graaff <graaff@gentoo.org>2022-07-05 07:15:36 +0200
commit337c9695711cc16ecffe7b45951450069e4dea27 (patch)
tree244a1a22db7687b6bd59bd94a96ed0eb2b910db9 /dev-ruby/simplecov_json_formatter
parentgames-emulation/openmsx: add missing harfbuzz dep (diff)
downloadgentoo-337c9695711cc16ecffe7b45951450069e4dea27.tar.gz
gentoo-337c9695711cc16ecffe7b45951450069e4dea27.tar.bz2
gentoo-337c9695711cc16ecffe7b45951450069e4dea27.zip
dev-ruby/simplecov_json_formatter: initial import of 0.1.4
Restrict tests because there are not many tests and they are strongly bound to a specific simplecov version. They are also not packaged in the gem. Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/simplecov_json_formatter')
-rw-r--r--dev-ruby/simplecov_json_formatter/Manifest1
-rw-r--r--dev-ruby/simplecov_json_formatter/metadata.xml11
-rw-r--r--dev-ruby/simplecov_json_formatter/simplecov_json_formatter-0.1.4.ebuild22
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/simplecov_json_formatter/Manifest b/dev-ruby/simplecov_json_formatter/Manifest
new file mode 100644
index 000000000000..1bb9762f6cd8
--- /dev/null
+++ b/dev-ruby/simplecov_json_formatter/Manifest
@@ -0,0 +1 @@
+DIST simplecov_json_formatter-0.1.4.gem 6656 BLAKE2B 57a03ca27911ed798ec2aa7e84a8d037e4565b0b9fec261d0a72d9276355ba27eb8fedea31195bc8b6e6b67b94b9a5f903f326720b862a46790bacd282e83c63 SHA512 1b90167acf4ad9565084488b455ee25ab8930a70a849191228e2868c15f29d257dc5256bb578e11351a942d887dcdeda9191a541cd0fb70e3f0eb8466fb13ddf
diff --git a/dev-ruby/simplecov_json_formatter/metadata.xml b/dev-ruby/simplecov_json_formatter/metadata.xml
new file mode 100644
index 000000000000..0670a7dfae0d
--- /dev/null
+++ b/dev-ruby/simplecov_json_formatter/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">codeclimate-community/simplecov_json_formatter</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/simplecov_json_formatter/simplecov_json_formatter-0.1.4.ebuild b/dev-ruby/simplecov_json_formatter/simplecov_json_formatter-0.1.4.ebuild
new file mode 100644
index 000000000000..5201e28824d9
--- /dev/null
+++ b/dev-ruby/simplecov_json_formatter/simplecov_json_formatter-0.1.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="JSON formatter for SimpleCov"
+HOMEPAGE="https://github.com/codeclimate-community/simplecov_json_formatter"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~riscv"
+SLOT="$(ver_cut 1)"
+IUSE="doc"
+
+# Not packaged in the gem and very fragile for e.g. simplecov versions
+RESTRICT="test"