summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-28 16:38:45 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:19:58 +0200
commit692dddaf8d69b7d52c851624330480800d94bd4d (patch)
treef0c7d5d11e546dfef4cfed419889568bf95b8070 /dev-ros/rqt_runtime_monitor
parentdev-ros/rqt_rviz: convert to python-single-r1 (diff)
downloadgentoo-692dddaf8d69b7d52c851624330480800d94bd4d.tar.gz
gentoo-692dddaf8d69b7d52c851624330480800d94bd4d.tar.bz2
gentoo-692dddaf8d69b7d52c851624330480800d94bd4d.zip
dev-ros/rqt_runtime_monitor: convert to python-single-r1
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_runtime_monitor')
-rw-r--r--dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.8.ebuild10
-rw-r--r--dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-9999.ebuild10
2 files changed, 10 insertions, 10 deletions
diff --git a/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.8.ebuild b/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.8.ebuild
index 6b0708cbe098..f15b3cdd299d 100644
--- a/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.8.ebuild
+++ b/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.8.ebuild
@@ -15,10 +15,10 @@ IUSE=""
RDEPEND="
dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-python/rospkg[${PYTHON_USEDEP}]
- dev-ros/qt_gui[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-ros/rqt_gui[${PYTHON_USEDEP}]
- dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/qt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-9999.ebuild b/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-9999.ebuild
index 6b0708cbe098..f15b3cdd299d 100644
--- a/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-9999.ebuild
+++ b/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-9999.ebuild
@@ -15,10 +15,10 @@ IUSE=""
RDEPEND="
dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-python/rospkg[${PYTHON_USEDEP}]
- dev-ros/qt_gui[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-ros/rqt_gui[${PYTHON_USEDEP}]
- dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/qt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}"