summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-11 13:49:45 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-11 13:59:48 +0200
commit63c6d8598aa5875ad3f24d30d7cda7a6e03e62c1 (patch)
treed7898d0da13c47f568c9c862c8dbac6a70a6be77 /dev-python
parentdev-python/translate-toolkit: Bump to 3.13.2 (diff)
downloadgentoo-63c6d8598aa5875ad3f24d30d7cda7a6e03e62c1.tar.gz
gentoo-63c6d8598aa5875ad3f24d30d7cda7a6e03e62c1.tar.bz2
gentoo-63c6d8598aa5875ad3f24d30d7cda7a6e03e62c1.zip
dev-python/puremagic: Bump to 1.26
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/puremagic/Manifest1
-rw-r--r--dev-python/puremagic/puremagic-1.26.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/puremagic/Manifest b/dev-python/puremagic/Manifest
index af931f99d430..3b66a91ffd11 100644
--- a/dev-python/puremagic/Manifest
+++ b/dev-python/puremagic/Manifest
@@ -1 +1,2 @@
DIST puremagic-1.25.gh.tar.gz 309788 BLAKE2B cc24e10ef59ce6299e7fb90b12b4d379d320d5795d475f9509301a050591c3404499227a64d6ed8395c8ab7f424561895966a3fe5dd1f90154fdb8be50fcab51 SHA512 7b9a8af827537ed9af38b80422744c7ee8b48b95f3344a79b6641cc7d55082160f20884659846a608d04d040acb06b0273fb8b51e5b92db14f92ff6d576c0e0d
+DIST puremagic-1.26.gh.tar.gz 310727 BLAKE2B ccb07fc646c90778bea98adc4bb63bcb24dd7e588134d12fae02b846e532ec3cfa0f29037ee9143ebdd9baf71703c73b1447886b86f4d7ca5a5b4097988a3570 SHA512 b081ab7b7ddc5ecfcf9b3f2a19535222ace2eed4e88872580eaae69f9635f59357d49ddcb01e7d88fa46556320e9c8906e7a44cb614288c88266f5f7d0109d49
diff --git a/dev-python/puremagic/puremagic-1.26.ebuild b/dev-python/puremagic/puremagic-1.26.ebuild
new file mode 100644
index 000000000000..7a5fd34c2d27
--- /dev/null
+++ b/dev-python/puremagic/puremagic-1.26.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python implementation of magic file detection"
+HOMEPAGE="
+ https://github.com/cdgriffith/puremagic/
+ https://pypi.org/project/puremagic/
+"
+SRC_URI="
+ https://github.com/cdgriffith/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( CHANGELOG.md README.rst )
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}