summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2024-10-28 19:39:21 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2024-10-28 19:39:21 +0100
commit846c8c0619c27ff8be0135ba8082f0f0bacfb1d3 (patch)
tree5f891bbebfe7b5bed325329a4ae2bfdf86b02686 /dev-python/pygccxml
parentdev-python/pygccxml: exclude failing single test with >=GCC-15.0.2 (diff)
downloadgentoo-846c8c0619c27ff8be0135ba8082f0f0bacfb1d3.tar.gz
gentoo-846c8c0619c27ff8be0135ba8082f0f0bacfb1d3.tar.bz2
gentoo-846c8c0619c27ff8be0135ba8082f0f0bacfb1d3.zip
dev-python/pygccxml: Fix test errors with >=sys-devel/clang-19.1.2
pygccxml uses dev-libs/castxml as a tool to parse a syntax tree. castxml uses clang for that task. Actual >=clang-19.1.2 needs '-fsized-deallocation' as additional compile flag. The patch provides these flag. Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'dev-python/pygccxml')
-rw-r--r--dev-python/pygccxml/files/pygccxml-2.5.0-fix-test-flags.patch10
-rw-r--r--dev-python/pygccxml/pygccxml-2.5.0.ebuild2
2 files changed, 12 insertions, 0 deletions
diff --git a/dev-python/pygccxml/files/pygccxml-2.5.0-fix-test-flags.patch b/dev-python/pygccxml/files/pygccxml-2.5.0-fix-test-flags.patch
new file mode 100644
index 000000000000..c96ef5e8d7ab
--- /dev/null
+++ b/dev-python/pygccxml/files/pygccxml-2.5.0-fix-test-flags.patch
@@ -0,0 +1,10 @@
+diff --git a/unittests/xml_generator.cfg b/unittests/xml_generator.cfg
+index cb00818..58899b6 100644
+--- a/unittests/xml_generator.cfg
++++ b/unittests/xml_generator.cfg
+@@ -15,3 +15,5 @@ include_paths=
+ compiler=
+ # Keep xml files after errors (useful for debugging)
+ keep_xml=
++# needed with clang-19
++cflags=-fsized-deallocation
diff --git a/dev-python/pygccxml/pygccxml-2.5.0.ebuild b/dev-python/pygccxml/pygccxml-2.5.0.ebuild
index b01b31fa4e77..ade79ae8d672 100644
--- a/dev-python/pygccxml/pygccxml-2.5.0.ebuild
+++ b/dev-python/pygccxml/pygccxml-2.5.0.ebuild
@@ -47,6 +47,8 @@ python_prepare_all() {
"${FILESDIR}/${PN}-2.4.0-doc.patch"
# https://github.com/CastXML/pygccxml/pull/179
"${FILESDIR}/${P}-which.patch"
+ # fixes tests with clang-19
+ "${FILESDIR}/${PN}-2.5.0-fix-test-flags.patch"
)
distutils-r1_python_prepare_all