summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-15 22:54:36 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-15 23:36:45 +0100
commit3535d710691ef91c2904fa0274d434abf9622af5 (patch)
tree89327f7b90d59719549ad0f430882c7220c3d964 /dev-python/django-allauth
parentdev-python/jupyter_packaging: Bump to 0.11.1 (diff)
downloadgentoo-3535d710691ef91c2904fa0274d434abf9622af5.tar.gz
gentoo-3535d710691ef91c2904fa0274d434abf9622af5.tar.bz2
gentoo-3535d710691ef91c2904fa0274d434abf9622af5.zip
dev-python/django-allauth: Bump to 0.46.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-allauth')
-rw-r--r--dev-python/django-allauth/Manifest1
-rw-r--r--dev-python/django-allauth/django-allauth-0.46.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/django-allauth/Manifest b/dev-python/django-allauth/Manifest
index 6d2086ef2ac4..fa7e7a90260c 100644
--- a/dev-python/django-allauth/Manifest
+++ b/dev-python/django-allauth/Manifest
@@ -1 +1,2 @@
DIST django-allauth-0.45.0.tar.gz 581007 BLAKE2B a0f586818e4d17ece5ed009481b71c0213bf265f45d391664d411268d53124c1d5df226ca40d98722691ace5f5ed50026b0a9db3bd34070ff855059bf3e237d6 SHA512 16b166a5f97e62fef3c801af17b6b7569bd27e597cec394032a2644397afc30512f52f0ff77af8036e414086cd207dc9f5d310dbc744627b55938243ba18e50f
+DIST django-allauth-0.46.0.tar.gz 643238 BLAKE2B 91534f596e3fa2e6fa5e395bded16a793ccbec994a3099eef22980920013280f58b2204d226975c2fe7a7e2066b665789881a9bcc6d2342f70a9eb0b83c32f6c SHA512 8e89d6d6a10566e40f71845885c30c36994aef3ff9054731a7582484d12ff4c7df7903617777698e42838337ae436c41a59a318acc1d2fc0561883683f79df46
diff --git a/dev-python/django-allauth/django-allauth-0.46.0.ebuild b/dev-python/django-allauth/django-allauth-0.46.0.ebuild
new file mode 100644
index 000000000000..815a68413f7c
--- /dev/null
+++ b/dev-python/django-allauth/django-allauth-0.46.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Django 3rd party (social) account authentication"
+HOMEPAGE="
+ https://www.intenct.nl/projects/django-allauth/
+ https://github.com/pennersr/django-allauth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# cryptography via pyjwt[crypto]
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
+ dev-python/python3-openid[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${RDEPEND} )"
+
+DOCS=( README.rst AUTHORS ChangeLog.rst )
+
+src_test() {
+ # cern provider tests require Internet
+ rm allauth/socialaccount/providers/cern/tests.py || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=test_settings
+ local -x PYTHONPATH=.
+ django-admin test -v 2 || die "Tests failed with ${EPYTHON}"
+}