summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-03-24 09:56:30 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-03-24 09:59:00 -0400
commita7122f82239daa8f0a26525b917d52d1504f30a8 (patch)
tree8d27335c25463034f080fe1379acbe868096068c /dev-php/adodb
parentmedia-gfx/freecad: add depend <sci-libs/opencascade-7.8.0 (diff)
downloadgentoo-a7122f82239daa8f0a26525b917d52d1504f30a8.tar.gz
gentoo-a7122f82239daa8f0a26525b917d52d1504f30a8.tar.bz2
gentoo-a7122f82239daa8f0a26525b917d52d1504f30a8.zip
dev-php/adodb: add 5.22.7
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php/adodb')
-rw-r--r--dev-php/adodb/Manifest1
-rw-r--r--dev-php/adodb/adodb-5.22.7.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/adodb/Manifest b/dev-php/adodb/Manifest
index f4102820ee49..3bfbc96143ef 100644
--- a/dev-php/adodb/Manifest
+++ b/dev-php/adodb/Manifest
@@ -1 +1,2 @@
DIST adodb-5.22.2.tar.gz 443988 BLAKE2B 1166c7b53a5ff39afe8d0a77cf56d2682e7f68d8f52f12ed9bf2519f4a15c626e26b590c7df3066f65bf6bbb7458be502d5a9e9b1ed2663286c51761fd58784c SHA512 50c2784f92e9ac372b34ed32d41efe82341dad09f269603359c50a30c9c301b7e65b2dfa75ae02cc7f12437ef57d8a9575e5a36e68d5b6e225fa1073ead3e339
+DIST adodb-5.22.7.tar.gz 447580 BLAKE2B 1d8e6518155585f7e82f697e463832c4d798dce0bc59fb4a068aef7430945fe7cbfb7112b150f36fc91fb9555189276032da420bec68a71c6438c1d513dd3594 SHA512 731e5def40699bc445b9ef44585b7db6f890d977aaafaac58ea1fcfadd9d89d00871a279549f6e8ff683fe56f7061d78cdc2457e99ed0636a8497cae44bddc99
diff --git a/dev-php/adodb/adodb-5.22.7.ebuild b/dev-php/adodb/adodb-5.22.7.ebuild
new file mode 100644
index 000000000000..7ba37d000ba5
--- /dev/null
+++ b/dev-php/adodb/adodb-5.22.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="ADOdb"
+DESCRIPTION="Database abstraction layer for PHP"
+HOMEPAGE="https://adodb.org/ https://github.com/ADOdb/ADOdb"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# If you want to be picky, we should require that PHP be built with at
+# least one database driver enabled; otherwise adodb isn't going to be
+# able to do anything. But, the database USE flags for dev-lang/php are
+# a mess. What we would *like* to do is have a set of USE flags for
+# adodb that then propagate to PHP itself... for example, adodb[mysql]
+# could require php[mysql]. To do that would require that we duplicate
+# the database USE flag mess for adodb -- not desirable. Instead we punt
+# and let the user install adodb unconditionally. If he doesn't have
+# database support in PHP, it just won't work.
+RDEPEND="dev-lang/php:*"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ DOCS="README.md docs/changelog*.md xmlschema*.dtd session/*.sql"
+ DOCS+=" session/*.txt session/*.xml pear/auth_adodb_example.php"
+ DOCS+=" pear/readme.Auth.txt"
+
+ dodoc ${DOCS}
+ rm -f ${DOCS} || die "failed to remove docs before installation"
+
+ insinto "/usr/share/php/${PN}"
+ doins *.php
+ doins -r datadict drivers lang pear perf session xsl
+}