summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-09 16:47:19 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-09 16:48:23 +1200
commitaf84e8ca90c3e93ff5a3ef7c07ea98099171b0cf (patch)
tree9c69c92008868fec41f467a178ab55222ac1c214 /dev-perl
parentapp-emulation/slirp4netns: Bump to version 1.1.3 (diff)
downloadgentoo-af84e8ca90c3e93ff5a3ef7c07ea98099171b0cf.tar.gz
gentoo-af84e8ca90c3e93ff5a3ef7c07ea98099171b0cf.tar.bz2
gentoo-af84e8ca90c3e93ff5a3ef7c07ea98099171b0cf.zip
dev-perl/DBI: Bump to version 1.643.0
- EAPI7 - Remove unused 'eutils' inherit - Unconditionally strip bad tests - Ensure CFLAGS passed to make/compiler Upstream: - Fix UTF-8 support for warn/croak within DBI internals - Add DBD::Mem driver for a pure perl in-memory driver based on DBI::DBD::SqlEngine - Add registration of mariadb_ prefix for DBD::MariaDB driver - Add compiler warnings in Driver.xst - Fix '.' in @INC in proxy test under parallel load - Fix driver-related croak() in DBI->connect to report the original DSN - Add new method $sth->last_insert_id() - Add new XS API function variant dbd_db_do6 - Fix memory corruption in XS functions when Perl stack is reallocated - Fix potentially calling newSV(0) in malloc_using_sv() - Fix order of XS prepares() ps_accept and ps_return argument names - Fix a potential NULL profile deref in dbi_profile() - Fix a buffer overflow on an overlong DBD class name - Remove remaining support for perl <5.8 - Update Devel::PPPort and remove redundant compat macros - Add new attribute RaiseWarn similar to RaiseError Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/DBI/DBI-1.643.0.ebuild47
-rw-r--r--dev-perl/DBI/Manifest1
-rw-r--r--dev-perl/DBI/metadata.xml7
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-perl/DBI/DBI-1.643.0.ebuild b/dev-perl/DBI/DBI-1.643.0.ebuild
new file mode 100644
index 000000000000..51958a4867e0
--- /dev/null
+++ b/dev-perl/DBI/DBI-1.643.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=TIMB
+DIST_VERSION=1.643
+DIST_EXAMPLES=("ex/*")
+inherit perl-module
+
+DESCRIPTION="Database independent interface for Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/PlRPC-0.200.0
+ >=virtual/perl-Sys-Syslog-0.170.0
+ virtual/perl-File-Spec
+ !<=dev-perl/SQL-Statement-1.330.0
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.480.0
+ test? (
+ >=virtual/perl-Test-Simple-0.900.0
+ )
+"
+PERL_RM_FILES=(
+ t/pod-coverage.t
+ t/pod.t
+)
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
+
+src_test() {
+ if [[ $(makeopts_jobs) -gt 70 ]]; then
+ einfo "Reducing jobs to 70. Bug: https://bugs.gentoo.org/675164"
+ MAKEOPTS="${MAKEOPTS} -j70";
+ fi
+ perl-module_src_test
+}
diff --git a/dev-perl/DBI/Manifest b/dev-perl/DBI/Manifest
index 40d2fb126833..d210289153a8 100644
--- a/dev-perl/DBI/Manifest
+++ b/dev-perl/DBI/Manifest
@@ -1 +1,2 @@
DIST DBI-1.637.tar.gz 596423 BLAKE2B fbd2100d302f5096d4c4f0808d753c0647504b6d56cae82050e02a3716969d9e5ed8c0a33c58fb860d60e65d164d58b1a81d55dc4e669d5276596b9e1480c7a4 SHA512 48002d77d40c40f0514d464a83f78255dc1a4c5ebb721fc18bcffa06d5f19ad7aec51084d5d8a032e37c6867b5f63176a9b11b5bdf08426f903b841139698240
+DIST DBI-1.643.tar.gz 612372 BLAKE2B 9a4b45bbf979d25e54f1ece056c3bb1d753a016e8da41b530788e69181027a9f974dd9c0d1939adceca3877c4b46d4113a2c234960b4d4bb9c12261301b920b8 SHA512 03812f3eb1e43c8290dadb8cb14bbced9ec6e237228ea2a2ba91f22e52143906a91a7e82945dab30b1d1b9fc925073721111adafd9a09fac070808ab88f908b8
diff --git a/dev-perl/DBI/metadata.xml b/dev-perl/DBI/metadata.xml
index 162537fa5d08..b670ec02cb80 100644
--- a/dev-perl/DBI/metadata.xml
+++ b/dev-perl/DBI/metadata.xml
@@ -40,6 +40,13 @@
<remote-id type="cpan-module">DBD::Gofer::db</remote-id>
<remote-id type="cpan-module">DBD::Gofer::dr</remote-id>
<remote-id type="cpan-module">DBD::Gofer::st</remote-id>
+ <remote-id type="cpan-module">DBD::Mem</remote-id>
+ <remote-id type="cpan-module">DBD::Mem::DataSource</remote-id>
+ <remote-id type="cpan-module">DBD::Mem::Statement</remote-id>
+ <remote-id type="cpan-module">DBD::Mem::Table</remote-id>
+ <remote-id type="cpan-module">DBD::Mem::db</remote-id>
+ <remote-id type="cpan-module">DBD::Mem::dr</remote-id>
+ <remote-id type="cpan-module">DBD::Mem::st</remote-id>
<remote-id type="cpan-module">DBD::NullP</remote-id>
<remote-id type="cpan-module">DBD::NullP::db</remote-id>
<remote-id type="cpan-module">DBD::NullP::dr</remote-id>