summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:10:30 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:18 +0100
commitff0a3a5b51e54577fec7288315a5b4c5c324667c (patch)
tree5def46e5f639714708d8d3574c8f90a5a1fd4b67 /dev-haskell/unicode-collation
parentdev-haskell/unbounded-delays: add 0.1.1.1 (diff)
downloadgentoo-ff0a3a5b51e54577fec7288315a5b4c5c324667c.tar.gz
gentoo-ff0a3a5b51e54577fec7288315a5b4c5c324667c.tar.bz2
gentoo-ff0a3a5b51e54577fec7288315a5b4c5c324667c.zip
dev-haskell/unicode-collation: add 0.1.3.4
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/unicode-collation')
-rw-r--r--dev-haskell/unicode-collation/Manifest1
-rw-r--r--dev-haskell/unicode-collation/metadata.xml4
-rw-r--r--dev-haskell/unicode-collation/unicode-collation-0.1.3.4.ebuild37
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/unicode-collation/Manifest b/dev-haskell/unicode-collation/Manifest
index 0614efd7a2ba..e5b667df1be1 100644
--- a/dev-haskell/unicode-collation/Manifest
+++ b/dev-haskell/unicode-collation/Manifest
@@ -1 +1,2 @@
DIST unicode-collation-0.1.3.3.tar.gz 2056081 BLAKE2B 1b5d58b852ff457b4c794d6e8c87c0539a5987240c2cdb8329fbb00b792be1105c194b55a10b5abd9c59eac7262194065d460a18e994edd2d7f71f535acb4f41 SHA512 bbb8fb3d52fa4906ddb92fb605f49b4c726cfcffd1f950c8a78bc495594a2e7d85fa78e2009da850f0218fce09a57f829ce0f3d6a6000b9b6484754f8c8260e8
+DIST unicode-collation-0.1.3.4.tar.gz 2056084 BLAKE2B e960e740aacd61dfde76fd1ea6da0e50319f91a5b9ea97d3ab95514bf13fd35957ed1b9d3883b980e488d1ef19fce2efda83aad68bc9cd83c5de9d6f3c23519f SHA512 88017dd6d8a96b4248fe993385bad8a5fbe134bdaab05b1f8956bc53c8abba927e22233eed6e3a1760c5cee928a9b2fc74bdb5c0c2c7be7e98bda0049852aec0
diff --git a/dev-haskell/unicode-collation/metadata.xml b/dev-haskell/unicode-collation/metadata.xml
index 88c9a1589f64..dc3a9336a589 100644
--- a/dev-haskell/unicode-collation/metadata.xml
+++ b/dev-haskell/unicode-collation/metadata.xml
@@ -10,4 +10,8 @@
Use with: @--write-ghc-environment-files=always@.</flag>
<flag name="executable">Build the unicode-collate executable.</flag>
</use>
+ <upstream>
+ <remote-id type="hackage">unicode-collation</remote-id>
+ <remote-id type="github">jgm/unicode-collation</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/unicode-collation/unicode-collation-0.1.3.4.ebuild b/dev-haskell/unicode-collation/unicode-collation-0.1.3.4.ebuild
new file mode 100644
index 000000000000..de116d72f284
--- /dev/null
+++ b/dev-haskell/unicode-collation/unicode-collation-0.1.3.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell implementation of the Unicode Collation Algorithm"
+HOMEPAGE="https://github.com/jgm/unicode-collation"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="doctests executable"
+
+RDEPEND="dev-haskell/parsec:=[profile?]
+ >=dev-haskell/text-1.2:=[profile?] <dev-haskell/text-2.1:=[profile?]
+ dev-haskell/th-lift-instances:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? ( dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck
+ >=dev-haskell/unicode-transforms-0.3.7.1
+ doctests? ( >=dev-haskell/doctest-0.8 ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag doctests doctests) \
+ $(cabal_flag executable executable)
+}