summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kołodziej <kacper@kolodziej.in>2016-10-15 18:48:18 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-21 23:23:11 +0200
commit4619d2046500054911918dc8325d72f34b534c5a (patch)
treeede81250d15f0c5772c459db41ab04163161c72c /dev-db/gigabase/gigabase-3.83-r2.ebuild
parentdev-lua/mpack: Bump to 1.0.3 (diff)
downloadgentoo-4619d2046500054911918dc8325d72f34b534c5a.tar.gz
gentoo-4619d2046500054911918dc8325d72f34b534c5a.tar.bz2
gentoo-4619d2046500054911918dc8325d72f34b534c5a.zip
dev-db/gigabase: fix cpp14 compilation errors; bug #594550
Package-Manager: portage-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/2584 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-db/gigabase/gigabase-3.83-r2.ebuild')
-rw-r--r--dev-db/gigabase/gigabase-3.83-r2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-db/gigabase/gigabase-3.83-r2.ebuild b/dev-db/gigabase/gigabase-3.83-r2.ebuild
new file mode 100644
index 000000000000..8dda26b603a6
--- /dev/null
+++ b/dev-db/gigabase/gigabase-3.83-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="OO-DBMS with interfaces for C/C++/Java/PHP/Perl"
+HOMEPAGE="http://www.garret.ru/~knizhnik/gigabase.html"
+SRC_URI="mirror://sourceforge/gigabase/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-dereferencing.patch"
+ "${FILESDIR}/${P}-cpp14.patch" # fix #594550
+ "${FILESDIR}/${P}-fix-build-system.patch"
+)
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ doxygen doxygen.cfg || die
+ HTML_DOCS=( GigaBASE.htm docs/html/. )
+ fi
+}
+
+src_test() {
+ local t
+ for t in testddl testidx testidx2 testiref testleak testperf \
+ testperf2 testspat testtl testsync testtimeseries; do
+ ./${t} || die
+ done
+}
+
+src_install() {
+ default
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}
+
+pkg_postinst() {
+ elog "The subsql binary has been renamed to subsql-gdb,"
+ elog "to avoid a name clash with the FastDB version of subsql"
+}