summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-04-07 16:19:35 +0200
committerDavid Seifert <soap@gentoo.org>2019-04-07 16:19:35 +0200
commit51f71cec6be5aa8ef68a091ac01c435b963703d0 (patch)
tree4914b90dc399d29fe508782fa95e9fd57af0ef83 /app-portage/ufed
parentapp-portage/ufed: Update live ebuild (diff)
downloadgentoo-51f71cec6be5aa8ef68a091ac01c435b963703d0.tar.gz
gentoo-51f71cec6be5aa8ef68a091ac01c435b963703d0.tar.bz2
gentoo-51f71cec6be5aa8ef68a091ac01c435b963703d0.zip
app-portage/ufed: Bump version to 0.93
* Fixes "unescaped left brace in regex" introduced with perl 5.28. Closes: https://bugs.gentoo.org/675332 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-portage/ufed')
-rw-r--r--app-portage/ufed/Manifest1
-rw-r--r--app-portage/ufed/ufed-0.93.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-portage/ufed/Manifest b/app-portage/ufed/Manifest
index 500c4215439a..125ad4dccae8 100644
--- a/app-portage/ufed/Manifest
+++ b/app-portage/ufed/Manifest
@@ -1,2 +1,3 @@
DIST ufed-0.91.tar.bz2 61466 BLAKE2B 63671c875f7dae13a6e76995204a278703691ed3c081a95853a6cbd9a57d1f88cf1c7625f1d524bfc1a816f1344282577126865160e0433cf6692d8067596f59 SHA512 34fc57b4d3fd1e8c4226401aec409ce4303294ec9044673ec62053b8dc6ade9d54419a5d208ba6767b75507bc9f8983a401dc258b0bae5b733e7a0c791554c35
DIST ufed-0.92.tar.bz2 61606 BLAKE2B b01c409d5852d59a3237748bff49348a2eab386d06c55389d5eee54ad1002575d67ab5138334e99ed2da434a8af05862d769fdf7e692bee2e77bd9c41b793762 SHA512 b1a608d026945144653f43ad322e54f0f1192d39fea3da2a4919e07de65445c75aa5e2d1e8cf9b24849c45f891a0de5952c92b3227f6c1200965f3c280611408
+DIST ufed-0.93.tar.bz2 48586 BLAKE2B b2af8f7c0e2a37331af9f0f1260737cee7beeb91b57a763b3e6dfc6d8069343af93297fd1585a853a9165744eeeb4dd48d618c44ce04c4363d9fd37562258214 SHA512 6c54747f25f935eb5e5c7dec259cd907680bb5a399779df9fa185019420091eede3dfb2a4bca64890e86f17530cfab9d5e7aad3e915a1d5fbcec606513b2b460
diff --git a/app-portage/ufed/ufed-0.93.ebuild b/app-portage/ufed/ufed-0.93.ebuild
new file mode 100644
index 000000000000..3a357527b718
--- /dev/null
+++ b/app-portage/ufed/ufed-0.93.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/ufed.git"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/ufed.git/snapshot/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+fi
+
+inherit autotools out-of-source
+
+DESCRIPTION="Gentoo Linux USE flags editor"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Ufed"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+COMMON_DEPEND="sys-libs/ncurses:0="
+RDEPEND="${COMMON_DEPEND}
+ dev-lang/perl"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ # Change the version number to reflect the ebuild version
+ local REPLACEMENT_VERSION_STR="${PVR}"
+ [[ ${PV} == *9999 ]] && REPLACEMENT_VERSION_STR+="-${EGIT_VERSION}"
+ sed -i "s:,\[git\],:,\[${REPLACEMENT_VERSION_STR}\],:" configure.ac || die
+
+ eautoreconf
+}