summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYongxiang Liang <tanekliang@gmail.com>2024-06-01 22:23:49 +0800
committerYixun Lan <dlan@gentoo.org>2024-06-02 03:24:05 +0000
commit5f0d87ed594a891b8dfbfb67414ca27fa005b2f2 (patch)
tree20913e99a56d323a170cad63a3d9e7d4c57ece4e /app-i18n
parentapp-i18n/fcitx: add 5.1.10 (diff)
downloadgentoo-5f0d87ed594a891b8dfbfb67414ca27fa005b2f2.tar.gz
gentoo-5f0d87ed594a891b8dfbfb67414ca27fa005b2f2.tar.bz2
gentoo-5f0d87ed594a891b8dfbfb67414ca27fa005b2f2.zip
app-i18n/fcitx-chinese-addons: add 5.1.6
Signed-off-by: Yongxiang Liang <tanekliang@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx-chinese-addons/Manifest1
-rw-r--r--app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.6.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-i18n/fcitx-chinese-addons/Manifest b/app-i18n/fcitx-chinese-addons/Manifest
index 69995159defa..ae0dd3b944a0 100644
--- a/app-i18n/fcitx-chinese-addons/Manifest
+++ b/app-i18n/fcitx-chinese-addons/Manifest
@@ -1,2 +1,3 @@
DIST fcitx5-chinese-addons-5.1.4_dict.tar.xz 885456 BLAKE2B 239b2092d9b4ca77d7c0373a85e7a0e5b03e223c477b8704e36657349cf3ba006791e77a064826cd452eb6e5e81d33831feceabb9a51a8d26275f70deb04658a SHA512 99f3cc101532879c126e2699d338528a25531b782a5c1f1e93cd363437567c1ba7b0173aca56f887089d4379e86aecf7977139b5b5c44d54e0bd9a416b01e976
DIST fcitx5-chinese-addons-5.1.5_dict.tar.zst 1007840 BLAKE2B dc7cfe09789a6d7ed5d820ebdae133648748478746b3da7ec93a7e1bf31db34d212459dd64e1887bb7cb4ab15f2846fab1d97cf4a17082129c9f4a6cbf819e76 SHA512 50559f1f2ffa89eb24ce58a14c3ca21f3c1092961ce90b925fcf89a029d65c0aee3601d89003be5e92f9f1697e72d5eb2dade06863256a9a615f8be9ec2b2fe5
+DIST fcitx5-chinese-addons-5.1.6_dict.tar.zst 1005756 BLAKE2B c3b3c12c3b269c71c7136ba140fa833fb28d4ff2698213aa47bdb3fe50ee65830a99c9591180ae0bfd2873c7d84013f26df895f2574372a64cdea9ea887cb052 SHA512 f130f4492977662916a1591048832a37ec306f3664a2c5bc5225ba220ea5ffebc3ef78022b2b6d2d8475b556285a0d45508eaf00473f5b636d2e56a7c73d2f38
diff --git a/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.6.ebuild b/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.6.ebuild
new file mode 100644
index 000000000000..22638f079ea1
--- /dev/null
+++ b/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5-chinese-addons"
+
+inherit cmake unpacker xdg
+
+DESCRIPTION="Addons related to Chinese, including IME previous bundled inside fcitx4."
+HOMEPAGE="https://github.com/fcitx/fcitx5-chinese-addons"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}_dict.tar.zst"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="+data +gui webengine +cloudpinyin +qt5 qt6 lua +opencc test"
+REQUIRED_USE="
+ webengine? ( gui )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-i18n/fcitx-5.1.9:5
+ >=app-i18n/libime-1.1.7:5[data?]
+ >=dev-libs/boost-1.61:=
+ cloudpinyin? ( net-misc/curl )
+ lua? ( app-i18n/fcitx-lua:5 )
+ opencc? ( app-i18n/opencc:= )
+ gui? (
+ qt5? (
+ dev-qt/qtconcurrent:5
+ app-i18n/fcitx-qt:5[qt5,-onlyplugin]
+ webengine? ( dev-qt/qtwebengine:5[widgets] )
+ )
+ qt6? (
+ dev-qt/qtbase:6[concurrent]
+ app-i18n/fcitx-qt:5[qt6,-onlyplugin]
+ webengine? ( dev-qt/qtwebengine:6[widgets] )
+ )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_BROWSER=$(usex webengine)
+ -DENABLE_CLOUDPINYIN=$(usex cloudpinyin)
+ -DENABLE_DATA=$(usex data)
+ -DENABLE_GUI=$(usex gui)
+ -DENABLE_OPENCC=$(usex opencc)
+ -DENABLE_TEST=$(usex test)
+ -DUSE_WEBKIT=no
+ -DUSE_QT6=$(usex qt6)
+ )
+ cmake_src_configure
+}