summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-08-04 15:57:01 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-08-04 15:59:32 +0200
commite72996f436c0cff1478bcbad56f78fa95f2e0b35 (patch)
tree2610830d52b220bb2b0660e1ec627ba5b30f21a2 /app-emulation/faudio
parentapp-benchmarks/stress-ng: add 0.18.02, drop 0.18.01 (diff)
downloadgentoo-e72996f436c0cff1478bcbad56f78fa95f2e0b35.tar.gz
gentoo-e72996f436c0cff1478bcbad56f78fa95f2e0b35.tar.bz2
gentoo-e72996f436c0cff1478bcbad56f78fa95f2e0b35.zip
app-emulation/faudio: add 24.08
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-emulation/faudio')
-rw-r--r--app-emulation/faudio/Manifest1
-rw-r--r--app-emulation/faudio/faudio-24.08.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-emulation/faudio/Manifest b/app-emulation/faudio/Manifest
index 9160e1fda8b7..51a56fe42159 100644
--- a/app-emulation/faudio/Manifest
+++ b/app-emulation/faudio/Manifest
@@ -1,2 +1,3 @@
DIST faudio-24.06.tar.gz 1125079 BLAKE2B 2664181d1fbed594b3f7af93877cb9f3ae1a9c34ed2e69d6307997e8b360045698d460912a1b689e060d9742fd002ce0370a6133dd944fa0b6e296949e679103 SHA512 d8fb3c2303c81163a26f437edce5ae428f4769a28107eb21f1fdb637421480928fc6f0031fc053caa762db901d659336a6e2ffad78ece9ab03ba4f312b00deb6
DIST faudio-24.07.tar.gz 1125108 BLAKE2B 4ff38ed79c3692f73850c31a0380df6cbafc156eff074e1384c3ef86af459769ba0c742a05b1ebd619b5d24e69bad761f1f7d01cebf526d4568d19e470f02e5a SHA512 bfb265d496c10e1e9fa032506c6de507ba04d5a1384f23cd07b7550b0fd427e78db8a66eede3717b4287ecb6d6695a13c888477d2686350bb7c936cbc6b74c7b
+DIST faudio-24.08.tar.gz 1125131 BLAKE2B a76da292ec74662413aa287147b83978f422d68077b62e3c8d5ad8a324ac1838d130d46ba8e7d32551221e55e73970ddc47ec06e20de905a6dc7cedacafc34fb SHA512 29777408b65ddc77e31d284730a0f3a08a973e29f6a492a7a9af5208b78279d40967ca593a55542aa3de7dd41deb82a31a6291a6bdffd56f04a91674276f95c6
diff --git a/app-emulation/faudio/faudio-24.08.ebuild b/app-emulation/faudio/faudio-24.08.ebuild
new file mode 100644
index 000000000000..e372ae484496
--- /dev/null
+++ b/app-emulation/faudio/faudio-24.08.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Accuracy-focused XAudio reimplementation for open platforms"
+HOMEPAGE="https://fna-xna.github.io/"
+SRC_URI="https://github.com/FNA-XNA/FAudio/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FAudio-${PV}"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug dumpvoices test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="media-libs/libsdl2[sound]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ append-cppflags -D_DEFAULT_SOURCE # usleep() in tests
+ use debug || append-cppflags -DFAUDIO_DISABLE_DEBUGCONFIGURATION
+
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ -DDUMP_VOICES=$(usex dumpvoices)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ einfo "Running faudio_tests, this may take some time without output..."
+ SDL_AUDIODRIVER=dummy "${BUILD_DIR}"/faudio_tests || die
+}