summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2024-10-07 00:34:59 -0700
committerGöktürk Yüksek <gokturk@gentoo.org>2024-10-07 00:40:55 -0700
commit1b7d723c70fda76183ac14a7cf3e3208dfd3a912 (patch)
tree430d94089475eabc58aea30e7634fd0339601961 /app-crypt
parentapp-text/asciidoc: Stabilize 10.2.1 amd64, #941095 (diff)
downloadgentoo-1b7d723c70fda76183ac14a7cf3e3208dfd3a912.tar.gz
gentoo-1b7d723c70fda76183ac14a7cf3e3208dfd3a912.tar.bz2
gentoo-1b7d723c70fda76183ac14a7cf3e3208dfd3a912.zip
app-crypt/jitterentropy: add 3.6.0
Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/jitterentropy/Manifest1
-rw-r--r--app-crypt/jitterentropy/jitterentropy-3.6.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-crypt/jitterentropy/Manifest b/app-crypt/jitterentropy/Manifest
index 7da1002321d2..3851d1a1f269 100644
--- a/app-crypt/jitterentropy/Manifest
+++ b/app-crypt/jitterentropy/Manifest
@@ -1 +1,2 @@
DIST jitterentropy-3.4.1.tar.gz 86110 BLAKE2B 729ef7d01a17c9eb16cc352da0286bd292f2faae63754b06036dbb44d52e85e2e2e0d2a38ac57d4350eaebbc47457f0457a988a657f7fe6c5d782d50922552d2 SHA512 c832b33c084a8c56fb9ee0c0f7397fa9206cbd6fcbea047495e543566fc0d9b5d8978c8668103203d87b5b70c0e177f9ef7cc614b3ce689b90fbb8b85e6fedbb
+DIST jitterentropy-3.6.0.tar.gz 96456 BLAKE2B 5e4fc185f16b59456a681e37f90de3b1e381bd6269bf72294822c1b8db11bbd5fe48640f2f38257c9b1238df38df7d95c2d1b9136b12364dde6e5cf3395c2e6e SHA512 8b234d0ac8115d004e8b1f41318e42d72324dfcbea0b3ba96499a6f9d740e13659c5bea032f77baad8d8ea3846fcd628665df573ab12b6111785f4bb5954834c
diff --git a/app-crypt/jitterentropy/jitterentropy-3.6.0.ebuild b/app-crypt/jitterentropy/jitterentropy-3.6.0.ebuild
new file mode 100644
index 000000000000..987687b0feb5
--- /dev/null
+++ b/app-crypt/jitterentropy/jitterentropy-3.6.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Hardware RNG based on CPU timing jitter"
+HOMEPAGE="https://github.com/smuellerDD/jitterentropy-library"
+SRC_URI="https://github.com/smuellerDD/jitterentropy-library/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-library-${PV}"
+
+# For future reference, tests/raw-entropy/validation-{restart,runtime}
+# have a weird license clause where it says:
+# The licensee IS NOT granted permission to redistribute the source code or
+# derivatives of the source code, and the binaries compiled from the source
+# code or its derivatives to any third parties.
+# Do not package these two components!
+LICENSE="BSD"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+
+ # Disable man page compression on install
+ sed -e '/\tgzip.*man/ d' -i Makefile || die
+}
+
+src_compile() {
+ # Upstream defines some of CFLAGS in the Makefile using '?='
+ # This allows those default flags to be overwritten by
+ # user-defined CFLAGS. Restore some of the defaults.
+ append-cflags '-fwrapv' '-fvisibility=hidden' '-fPIE'
+ # Optimizations are not allowed by upstream, which already
+ # overrides CFLAGS in Makefile. We need to handle CPPFLAGS here.
+ append-cppflags '-O0'
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" \
+ LIBDIR="$(get_libdir)" \
+ DESTDIR="${D}" \
+ INSTALL_STRIP="install" \
+ install $(usex static-libs install-static '')
+}