summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-10-02 14:27:27 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-10-02 14:27:54 +0200
commit178aebb01cac4b4606f39233a3ed52d3d8e45eaf (patch)
treebff3723de047ff352a51543a4ac25532e664b2d9 /app-benchmarks
parentmedia-libs/munt-mt32emu: Drop old 2.5.1 (diff)
downloadgentoo-178aebb01cac4b4606f39233a3ed52d3d8e45eaf.tar.gz
gentoo-178aebb01cac4b4606f39233a3ed52d3d8e45eaf.tar.bz2
gentoo-178aebb01cac4b4606f39233a3ed52d3d8e45eaf.zip
app-benchmarks/stress: bump to version 1.0.5
This is also a switch to the debian fork, which took it up and seems to continue to develop it. Old upstream is gone, as homepage is not reachable anymore. Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/stress/Manifest1
-rw-r--r--app-benchmarks/stress/stress-1.0.5.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-benchmarks/stress/Manifest b/app-benchmarks/stress/Manifest
index 5669caef088c..b3d7c8e1d38e 100644
--- a/app-benchmarks/stress/Manifest
+++ b/app-benchmarks/stress/Manifest
@@ -1 +1,2 @@
DIST stress-1.0.4-r1.tar.gz 191800 BLAKE2B 560065d963823e734bb706840908998a58c07c82b21ab579f7a0fd5163e7a8591ca0f6abe430bba058bafd9a2dac1fcf33f011663cd6c3d2fdefb221a49e5e8f SHA512 623a7d9585828bed4b7673e19fb0cfdda904552cd56353d74106047b64249299d5f8da892ec135f1781ec3984c7d5835dcc6c0d8e659e06c8a1e4fb2af9fd9c4
+DIST stress_1.0.5.orig.tar.gz 105766 BLAKE2B 7bc4a1d7739828ccd4b58c814e8ded42cddbd0b226bb29e916fe220835bcfa9dcdb86191bb321247aa98bd0e58791556713770bdeda5dad399aa61f2703a766c SHA512 8ae2b74213e2a6e7d17948b8277bdd6143c135a6cee64fb43d183b10134eaea761981e1d76af86ea4700b2d41598d5ca53b17755e61982ab50802297b139b805
diff --git a/app-benchmarks/stress/stress-1.0.5.ebuild b/app-benchmarks/stress/stress-1.0.5.ebuild
new file mode 100644
index 000000000000..60a9c7e1e06d
--- /dev/null
+++ b/app-benchmarks/stress/stress-1.0.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A deliberately simple workload generator for POSIX systems"
+HOMEPAGE="https://salsa.debian.org/debian/stress"
+SRC_URI="mirror://debian/pool/main/s/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static)
+ )
+
+ econf "${myeconfargs[@]}"
+}