summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChi-Thanh Christopher Nguyen <chithanh@gentoo.org>2013-04-28 14:53:27 +0200
committerChi-Thanh Christopher Nguyen <chithanh@gentoo.org>2013-04-28 14:53:27 +0200
commit9af789d85685393d4a9c79897caaf67281a061da (patch)
tree264779edef2dfb65f6d672e5d0b341c87cd07024
parentmedia-video/mpv: included in portage, removing x11 from overlay (diff)
downloadx11-9af789d85685393d4a9c79897caaf67281a061da.tar.gz
x11-9af789d85685393d4a9c79897caaf67281a061da.tar.bz2
x11-9af789d85685393d4a9c79897caaf67281a061da.zip
media-libs/mesa: add flags for building the ilo driver
-rw-r--r--media-libs/mesa/files/eselect-mesa.conf.8.138
-rw-r--r--media-libs/mesa/mesa-9999.ebuild21
2 files changed, 12 insertions, 47 deletions
diff --git a/media-libs/mesa/files/eselect-mesa.conf.8.1 b/media-libs/mesa/files/eselect-mesa.conf.8.1
deleted file mode 100644
index 63a21aa4..00000000
--- a/media-libs/mesa/files/eselect-mesa.conf.8.1
+++ /dev/null
@@ -1,38 +0,0 @@
-# mesa classic/gallium implementations in this release
-
-# Syntax description:
-# * MESA_IMPLEMENTATIONS contains a space-delimited list of switchable
-# classic/gallium implementations.
-# * MESA_DRIVERS is an associative array, for each member "foo" of
-# MESA_IMPLEMENTATIONS it contains the following elements:
-# foo,description - Human-readable description of the driver
-# foo,classicdriver - Filename of the classic driver
-# foo,galliumdriver - Filename of the gallium driver
-# foo,default - which of classic or gallium is chosen by default
-
-MESA_IMPLEMENTATIONS="i915 i965 r300 r600 sw"
-declare -A MESA_DRIVERS || die "MESA_DRIVERS already in environment and not associative."
-
-MESA_DRIVERS[i915,description]="i915 (Intel 915, 945)"
-MESA_DRIVERS[i915,classicdriver]="i915_dri.so"
-MESA_DRIVERS[i915,galliumdriver]="i915g_dri.so"
-MESA_DRIVERS[i915,default]="gallium"
-
-MESA_DRIVERS[i965,description]="i965 (Intel 965, G/Q3x, G/Q4x)"
-MESA_DRIVERS[i965,classicdriver]="i965_dri.so"
-MESA_DRIVERS[i965,default]="classic"
-
-MESA_DRIVERS[r300,description]="r300 (Radeon R300-R500)"
-MESA_DRIVERS[r300,classicdriver]="r300_dri.so"
-MESA_DRIVERS[r300,galliumdriver]="r300g_dri.so"
-MESA_DRIVERS[r300,default]="gallium"
-
-MESA_DRIVERS[r600,description]="r600 (Radeon R600-R700, Evergreen, Northern Islands)"
-MESA_DRIVERS[r600,classicdriver]="r600_dri.so"
-MESA_DRIVERS[r600,galliumdriver]="r600g_dri.so"
-MESA_DRIVERS[r600,default]="gallium"
-
-MESA_DRIVERS[sw,description]="sw (Software renderer)"
-MESA_DRIVERS[sw,classicdriver]="swrast_dri.so"
-MESA_DRIVERS[sw,galliumdriver]="swrastg_dri.so"
-MESA_DRIVERS[sw,default]="gallium"
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 4c015b41..3d020b4d 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -40,7 +40,7 @@ LICENSE="MIT SGI-B-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
-INTEL_CARDS="i915 i965 intel"
+INTEL_CARDS="i915 i965 ilo intel"
RADEON_CARDS="r100 r200 r300 r600 radeon radeonsi"
VIDEO_CARDS="${INTEL_CARDS} ${RADEON_CARDS} nouveau vmware"
for card in ${VIDEO_CARDS}; do
@@ -64,7 +64,7 @@ REQUIRED_USE="
xorg? ( gallium )
video_cards_intel? ( || ( classic gallium ) )
video_cards_i915? ( || ( classic gallium ) )
- video_cards_i965? ( classic )
+ video_cards_i965? ( || ( classic gallium ) )
video_cards_nouveau? ( || ( classic gallium ) )
video_cards_radeon? ( || ( classic gallium ) )
video_cards_r100? ( classic )
@@ -75,7 +75,7 @@ REQUIRED_USE="
video_cards_vmware? ( gallium )
"
-LIBDRM_DEPSTRING=">=x11-libs/libdrm-2.4.40"
+LIBDRM_DEPSTRING=">=x11-libs/libdrm-2.4.44"
# keep correct libdrm and dri2proto dep
# keep blocks in rdepend for binpkg
RDEPEND="
@@ -189,8 +189,9 @@ src_configure() {
# Intel code
driver_enable video_cards_i915 i915
driver_enable video_cards_i965 i965
- if ! use video_cards_i915 && \
- ! use video_cards_i965; then
+ if ! use video_cards_i915 && \
+ ! use video_cards_i965 && \
+ ! use video_cards_ilo; then
driver_enable video_cards_intel i915 i965
fi
@@ -225,8 +226,10 @@ src_configure() {
gallium_enable video_cards_vmware svga
gallium_enable video_cards_nouveau nouveau
gallium_enable video_cards_i915 i915
- if ! use video_cards_i915; then
- gallium_enable video_cards_intel i915
+ gallium_enable video_cards_ilo ilo
+ if ! use video_cards_i915 && \
+ ! use video_cards_ilo; then
+ gallium_enable video_cards_intel i915 ilo
fi
gallium_enable video_cards_r300 r300
@@ -280,7 +283,7 @@ src_install() {
# Install config file for eselect mesa
insinto /usr/share/mesa
- newins "${FILESDIR}/eselect-mesa.conf.8.1" eselect-mesa.conf
+ newins "${FILESDIR}/eselect-mesa.conf.9.2" eselect-mesa.conf
# Move libGL and others from /usr/lib to /usr/lib/opengl/blah/lib
# because user can eselect desired GL provider.
@@ -310,7 +313,7 @@ src_install() {
if use classic || use gallium; then
ebegin "Moving DRI/Gallium drivers for dynamic switching"
- local gallium_drivers=( i915_dri.so i965_dri.so r300_dri.so r600_dri.so swrast_dri.so )
+ local gallium_drivers=( i915_dri.so ilo_dri.so r300_dri.so r600_dri.so swrast_dri.so )
keepdir /usr/$(get_libdir)/dri
dodir /usr/$(get_libdir)/mesa
for x in ${gallium_drivers[@]}; do