aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml41
1 files changed, 41 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..c6b344d
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,41 @@
+[build-system]
+requires = ["setuptools"]
+build-backend = "setuptools.build_meta"
+
+[project]
+name = "tyrian-sphinx-theme"
+authors = [
+ {name = "Max Magorsch", email = "max@magorsch.de"},
+]
+description = "A Tyrian based Sphinx theme for Gentoo"
+readme = {file = "README.md", content-type = "text/markdown"}
+requires-python = ">=3.8"
+license = {text = "BSD-2-Clause"}
+classifiers = [
+ "Framework :: Sphinx",
+ "Framework :: Sphinx :: Theme",
+ "Operating System :: OS Independent",
+ "License :: OSI Approved :: BSD License",
+ "Programming Language :: Python :: 3",
+]
+dynamic = ["version"]
+
+[project.urls]
+Homepage = "https://gitweb.gentoo.org/proj/tyrian-sphinx-theme.git"
+
+[project.entry-points."sphinx.html_themes"]
+tyrian_sphinx_theme = "tyrian_sphinx_theme"
+
+[tool.setuptools]
+packages = ["tyrian_sphinx_theme"]
+
+[tool.setuptools.package-data]
+tyrian_sphinx_theme = [
+ "theme.conf",
+ "*.html",
+ "static/*.css",
+ "static/*.css_t",
+]
+
+[tool.setuptools.dynamic]
+version = {attr = "tyrian_sphinx_theme._version.__version__"}