aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-12-03 00:27:56 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-12-03 00:27:56 +0100
commitef30e8a1e8ba6e56b365f8dbaddd1b4812306392 (patch)
tree4ee8547b6b94254fd003059d54addc75c5545c2f /sci-biology/ncbi-tools++
parentsci-biology/ensembl-tools: add missing dependency (diff)
downloadsci-ef30e8a1e8ba6e56b365f8dbaddd1b4812306392.tar.gz
sci-ef30e8a1e8ba6e56b365f8dbaddd1b4812306392.tar.bz2
sci-ef30e8a1e8ba6e56b365f8dbaddd1b4812306392.zip
sci-biology/ncbi-tools++: fix bug #579248#c by disabling more tests
This will likely also fix the #579248 bug in rmblast (untested). Our $FILESDIR/disable-testsuite-compilation.txt only excludes test applications from usingboost, not the support library. Hence the above bug. We could either add --without-boost to the configuration command line to disable the bosost-related code in support library or, which is the path we take in this commit, we disable building of the yet escaping unit_tests which needed boost. Upstream further said: The C++ Toolkit makes very little use of Boost outside of unit tests, but that's a fair question. The simplest fix preserving other uses of Boost would be to edit .../src/corelib/Makefile.in and remove test_boost from LIB_PROJ. (You'll still also need to exclude building the tests by adding '-.*/unit_tests' to the $FILESDIR/disable-testsuite-compilation.txt file.) Package-Manager: portage-2.3.2
Diffstat (limited to 'sci-biology/ncbi-tools++')
-rw-r--r--sci-biology/ncbi-tools++/files/disable-testsuite-compilation.txt1
-rw-r--r--sci-biology/ncbi-tools++/files/ncbi-tools++-12.0.0-never_build_test_boost.patch11
-rw-r--r--sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild1
3 files changed, 13 insertions, 0 deletions
diff --git a/sci-biology/ncbi-tools++/files/disable-testsuite-compilation.txt b/sci-biology/ncbi-tools++/files/disable-testsuite-compilation.txt
index aeaf75e45..8df346f64 100644
--- a/sci-biology/ncbi-tools++/files/disable-testsuite-compilation.txt
+++ b/sci-biology/ncbi-tools++/files/disable-testsuite-compilation.txt
@@ -1,3 +1,4 @@
.*
-.*/test
-.*/unit_test
+-.*/unit_tests
diff --git a/sci-biology/ncbi-tools++/files/ncbi-tools++-12.0.0-never_build_test_boost.patch b/sci-biology/ncbi-tools++/files/ncbi-tools++-12.0.0-never_build_test_boost.patch
new file mode 100644
index 000000000..68baea046
--- /dev/null
+++ b/sci-biology/ncbi-tools++/files/ncbi-tools++-12.0.0-never_build_test_boost.patch
@@ -0,0 +1,11 @@
+--- ncbi_cxx--12_0_0/src/corelib/Makefile.in.ori 2016-12-01 20:28:33.239758102 +0100
++++ ncbi_cxx--12_0_0/src/corelib/Makefile.in 2016-12-01 20:28:46.330110659 +0100
+@@ -7,7 +7,7 @@
+ #################################
+
+ USR_PROJ = precompile
+-LIB_PROJ = corelib test_mt test_boost
++LIB_PROJ = corelib test_mt
+ SUB_PROJ = test
+ PROJ_TAG = core
+
diff --git a/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild b/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild
index c9f69112d..1236c1353 100644
--- a/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild
+++ b/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild
@@ -120,6 +120,7 @@ src_prepare() {
"${FILESDIR}"/${P}-drop-STATIC-from-LIB.patch
"${FILESDIR}"/${P}-fix-install.patch
"${FILESDIR}"/${P}-bdb6.patch
+ "${FILESDIR}"/${P}-never_build_test_boost.patch # bug #579248
)
# "${FILESDIR}"/${P}-as-needed.patch
# "${FILESDIR}"/${P}-fix-creaders-linking.patch