aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-12-30 17:45:55 +0100
committerHorea Christian <chr@chymera.eu>2021-01-02 22:31:15 -0500
commit022d5da8a7b0fa7d16141aa2f250b10f7962adea (patch)
tree089b8ef72b6fb09a8b8fda7e1eb7b4f05b9d08a6 /dev-python/traits
parentapp-doc/blacs-docs: remove obsolete package (diff)
downloadsci-022d5da8a7b0fa7d16141aa2f250b10f7962adea.tar.gz
sci-022d5da8a7b0fa7d16141aa2f250b10f7962adea.tar.bz2
sci-022d5da8a7b0fa7d16141aa2f250b10f7962adea.zip
dev-python/traits: version bump, cleanup ebuild
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python/traits')
-rw-r--r--dev-python/traits/Manifest3
-rw-r--r--dev-python/traits/traits-5.1.0.ebuild43
-rw-r--r--dev-python/traits/traits-6.1.1.ebuild (renamed from dev-python/traits/traits-6.0.0.ebuild)20
3 files changed, 7 insertions, 59 deletions
diff --git a/dev-python/traits/Manifest b/dev-python/traits/Manifest
index 088a6ad6a..758817ea9 100644
--- a/dev-python/traits/Manifest
+++ b/dev-python/traits/Manifest
@@ -1,2 +1 @@
-DIST traits-5.1.0.tar.gz 436687 BLAKE2B c46deb168019a8c3039f11104e55051068803cedf29de91b36a1020e03e842202874c60cf24134a5ef95afdced11195ec85e0514211ed23fe2a81625e76ef4bb SHA512 b267fefa97da1aced3cb9937e2cb50c7dd86b93da6d77edf2e12b44c854505cfef1077679f0a8652119b42356b5e8f1be47d7ae41915bbec21c559db212cb0ca
-DIST traits-6.0.0.tar.gz 441607 BLAKE2B d8f28e8ccdca8d65a4abb71210f6fe36d6fd2eb07ce5e8f1d374a64cf44e9ce95a318274c68b6791c91f2e105c4f9385e4a743d33434b608ce1d939693958e33 SHA512 b89f844b18c97e2fd2239fc74253e83f255aa231a3d02207a5acf27da7686c32c57cb7c36ffb92a59f7bfa4d98a5e1a95ae2b70e34aa4577a7ae82c8c6756e1e
+DIST traits-6.1.1.tar.gz 567019 BLAKE2B 4b6ed46c87b1fda2a2001299106b5aacafbe8b148ba0564c4f39b67a8de76f6713366c8b00841db254a26c87a7b2b73b6935ecade770d92ad972aa8a0425cecf SHA512 7f7e9f11d4861c02164ae1ce595888859c8ce23213290cfc3ac11df100d33beeeea4c7def6799b70ef2d090b3f7bd98407f3605affff0867914d0fe0164dd50f
diff --git a/dev-python/traits/traits-5.1.0.ebuild b/dev-python/traits/traits-5.1.0.ebuild
deleted file mode 100644
index e575e72a0..000000000
--- a/dev-python/traits/traits-5.1.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
-HOMEPAGE="http://docs.enthought.com/traits/
- https://github.com/enthought/traits
- https://pypi.org/project/traits/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- ${RDEPEND}
- )"
-
-python_prepare_all() {
- sed -i -e "s/'-O3'//g" setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- nosetests || die
-}
diff --git a/dev-python/traits/traits-6.0.0.ebuild b/dev-python/traits/traits-6.1.1.ebuild
index f109a0c09..a5258b8a5 100644
--- a/dev-python/traits/traits-6.0.0.ebuild
+++ b/dev-python/traits/traits-6.1.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1 virtualx
@@ -15,28 +15,20 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- ${RDEPEND}
- )"
+distutils_enable_tests nose
+# ToDo: Fix doc building:
+# AttributeError: 'NoDefaultSpecified' object has no attribute '__name__'
+#distutils_enable_sphinx docs/source --no-autodoc
python_prepare_all() {
sed -i -e "s/'-O3'//g" setup.py || die
distutils-r1_python_prepare_all
}
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
python_test() {
cd "${BUILD_DIR}"/lib || die
${EPYTHON} -m unittest discover || die