aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.gpyutils')
-rw-r--r--Makefile.gpyutils12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.gpyutils b/Makefile.gpyutils
index 940ad8e..f8fb1b8 100644
--- a/Makefile.gpyutils
+++ b/Makefile.gpyutils
@@ -6,7 +6,7 @@ timestamp = $(PORTDIR)/metadata/timestamp.commit
outdir = /dev/null
# upgrades for stable impls
-upgr_base = $(outdir)/36-to-37.txt $(outdir)/37-to-38.txt
+upgr_base = $(outdir)/36-to-37.txt $(outdir)/37-to-38.txt $(outdir)/38-to-39.txt
# related stabilizations
upgr_streq = $(patsubst %.txt,%-stablereq.txt,$(upgr_base))
# all upgrade stuff
@@ -59,6 +59,16 @@ $(outdir)/37-to-38-stablereq.txt: $(timestamp)
gpy-upgrade-impl -s python3_7 python3_8 > $@.new
mv $@.new $@
+$(outdir)/38-to-39.txt: $(timestamp)
+ mkdir -p $(outdir)
+ gpy-upgrade-impl python3_8 python3_9 > $@.new
+ mv $@.new $@
+
+$(outdir)/38-to-39-stablereq.txt: $(timestamp)
+ mkdir -p $(outdir)
+ gpy-upgrade-impl -s python3_8 python3_9 > $@.new
+ mv $@.new $@
+
%.dot: %.txt
gpy-depgraph -m python@gentoo.org $< > $@.new
mv $@.new $@