aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2012-05-20 11:29:05 -0400
committertitan <titan@goffman.(none)>2012-05-20 11:30:34 -0400
commit7d10b22de840840f355a8c3c5e926f740f48aa58 (patch)
tree5b1150a4965dbd0683f0d5ab871088a121f87810
parentSocket directory can be /run or /var/run now. (diff)
downloadpatches-7d10b22de840840f355a8c3c5e926f740f48aa58.tar.gz
patches-7d10b22de840840f355a8c3c5e926f740f48aa58.tar.bz2
patches-7d10b22de840840f355a8c3c5e926f740f48aa58.zip
Initial commit for 9.2.
-rw-r--r--autoconf.patch8
-rw-r--r--base.patch28
-rw-r--r--bool.patch4
-rw-r--r--regress.patch34
-rw-r--r--server.patch72
5 files changed, 70 insertions, 76 deletions
diff --git a/autoconf.patch b/autoconf.patch
index e68a853..1a0d62c 100644
--- a/autoconf.patch
+++ b/autoconf.patch
@@ -1,14 +1,14 @@
diff -Naur a/configure.in b/configure.in
---- a/configure.in 2011-09-08 17:13:27.000000000 -0400
-+++ b/configure.in 2011-09-16 21:49:14.560579320 -0400
+--- a/configure.in 2012-05-10 18:35:09.000000000 -0400
++++ b/configure.in 2012-05-16 10:08:26.709844367 -0400
@@ -19,10 +19,6 @@
- AC_INIT([PostgreSQL], [9.1.0], [pgsql-bugs@postgresql.org])
+ AC_INIT([PostgreSQL], [9.2beta1], [pgsql-bugs@postgresql.org])
-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.63], [], [m4_fatal([Autoconf version 2.63 is required.
-Untested combinations of 'autoconf' and PostgreSQL versions are not
-recommended. You can remove the check from 'configure.in' but it is then
-your responsibility whether the result works or not.])])
- AC_COPYRIGHT([Copyright (c) 1996-2011, PostgreSQL Global Development Group])
+ AC_COPYRIGHT([Copyright (c) 1996-2012, PostgreSQL Global Development Group])
AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
AC_CONFIG_AUX_DIR(config)
diff --git a/base.patch b/base.patch
index 3d43225..20afa59 100644
--- a/base.patch
+++ b/base.patch
@@ -1,7 +1,7 @@
diff -Naur a/contrib/Makefile b/contrib/Makefile
---- a/contrib/Makefile 2011-09-08 17:13:27.000000000 -0400
-+++ b/contrib/Makefile 2011-09-16 21:58:34.080579316 -0400
-@@ -5,56 +5,10 @@
+--- a/contrib/Makefile 2012-05-10 18:35:09.000000000 -0400
++++ b/contrib/Makefile 2012-05-20 09:33:47.892622992 -0400
+@@ -5,58 +5,10 @@
include $(top_builddir)/src/Makefile.global
SUBDIRS = \
@@ -35,6 +35,7 @@ diff -Naur a/contrib/Makefile b/contrib/Makefile
- pg_standby \
- pg_stat_statements \
- pg_test_fsync \
+- pg_test_timing \
- pg_trgm \
- pg_upgrade \
- pg_upgrade_support \
@@ -45,6 +46,7 @@ diff -Naur a/contrib/Makefile b/contrib/Makefile
- seg \
- spi \
- tablefunc \
+- tcn \
- test_parser \
- tsearch2 \
- unaccent \
@@ -59,8 +61,8 @@ diff -Naur a/contrib/Makefile b/contrib/Makefile
ifeq ($(with_ossp_uuid),yes)
SUBDIRS += uuid-ossp
diff -Naur a/src/backend/Makefile b/src/backend/Makefile
---- a/src/backend/Makefile 2011-09-08 17:13:27.000000000 -0400
-+++ b/src/backend/Makefile 2011-09-16 22:01:48.400579314 -0400
+--- a/src/backend/Makefile 2012-05-10 18:35:09.000000000 -0400
++++ b/src/backend/Makefile 2012-05-20 09:36:24.446654842 -0400
@@ -45,7 +45,7 @@
##########################################################################
@@ -79,7 +81,7 @@ diff -Naur a/src/backend/Makefile b/src/backend/Makefile
# run this unconditionally to avoid needing to know its dependencies here:
submake-schemapg:
-@@ -206,23 +206,7 @@
+@@ -207,23 +207,7 @@
##########################################################################
@@ -105,8 +107,8 @@ diff -Naur a/src/backend/Makefile b/src/backend/Makefile
install-bin: postgres $(POSTGRES_IMP) installdirs
$(INSTALL_PROGRAM) postgres$(X) '$(DESTDIR)$(bindir)/postgres$(X)'
diff -Naur a/src/bin/Makefile b/src/bin/Makefile
---- a/src/bin/Makefile 2011-09-08 17:13:27.000000000 -0400
-+++ b/src/bin/Makefile 2011-09-16 22:03:48.250579314 -0400
+--- a/src/bin/Makefile 2012-05-10 18:35:09.000000000 -0400
++++ b/src/bin/Makefile 2012-05-20 09:41:18.489958216 -0400
@@ -13,8 +13,7 @@
top_builddir = ../..
include $(top_builddir)/src/Makefile.global
@@ -118,9 +120,9 @@ diff -Naur a/src/bin/Makefile b/src/bin/Makefile
ifeq ($(PORTNAME), win32)
SUBDIRS += pgevent
diff -Naur a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
---- a/src/include/pg_config_manual.h 2011-09-08 17:13:27.000000000 -0400
-+++ b/src/include/pg_config_manual.h 2011-09-16 22:27:52.480579304 -0400
-@@ -141,7 +141,7 @@
+--- a/src/include/pg_config_manual.h 2012-05-10 18:35:09.000000000 -0400
++++ b/src/include/pg_config_manual.h 2012-05-20 09:38:48.325846035 -0400
+@@ -144,7 +144,7 @@
* here's where to twiddle it. You can also override this at runtime
* with the postmaster's -k switch.
*/
@@ -130,8 +132,8 @@ diff -Naur a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
/*
* The random() function is expected to yield values between 0 and
diff -Naur a/src/Makefile b/src/Makefile
---- a/src/Makefile 2011-09-08 17:13:27.000000000 -0400
-+++ b/src/Makefile 2011-09-16 22:29:17.650579302 -0400
+--- a/src/Makefile 2012-05-10 18:35:09.000000000 -0400
++++ b/src/Makefile 2012-05-20 09:40:13.532774840 -0400
@@ -14,17 +14,11 @@
SUBDIRS = \
diff --git a/bool.patch b/bool.patch
index 53f502a..c4dff83 100644
--- a/bool.patch
+++ b/bool.patch
@@ -1,6 +1,6 @@
diff -Naur a/src/include/c.h b/src/include/c.h
---- a/src/include/c.h 2011-08-18 17:23:13.000000000 -0400
-+++ b/src/include/c.h 2011-08-27 14:48:50.154729275 -0400
+--- a/src/include/c.h 2012-05-10 18:35:09.000000000 -0400
++++ b/src/include/c.h 2012-05-20 09:45:37.489702149 -0400
@@ -179,6 +179,7 @@
*/
diff --git a/regress.patch b/regress.patch
index cf706a6..2c5883a 100644
--- a/regress.patch
+++ b/regress.patch
@@ -1,53 +1,51 @@
-diff -Naur a/src/test/regress/pg_regress.c b/src/test/regress/pg_regress.c
---- a/src/test/regress/pg_regress.c 2011-04-27 17:17:22.000000000 -0400
-+++ b/src/test/regress/pg_regress.c 2011-05-02 19:01:20.470763739 -0400
-@@ -806,7 +806,7 @@
+diff -Naurw a/src/test/regress/pg_regress.c b/src/test/regress/pg_regress.c
+--- a/src/test/regress/pg_regress.c 2012-05-10 18:35:09.000000000 -0400
++++ b/src/test/regress/pg_regress.c 2012-05-20 09:56:07.126786540 -0400
+@@ -798,7 +798,7 @@
datadir = tmp;
/* psql will be installed into temp-install bindir */
- psqldir = bindir;
-+ /* psqldir = bindir; */
++ /* psqldir = bindir; */
/*
* Set up shared library paths to include the temp install.
-@@ -906,7 +906,7 @@
+@@ -898,7 +898,7 @@
/* And now we can build and execute the shell command */
snprintf(psql_cmd, sizeof(psql_cmd),
- SYSTEMQUOTE "\"%s%spsql\" -X -c \"%s\" \"%s\"" SYSTEMQUOTE,
-+ SYSTEMQUOTE "\"%s%spsql\" -h @SOCKETDIR@ -X -c \"%s\" \"%s\"" SYSTEMQUOTE,
++ SYSTEMQUOTE "\"%s%spsql\" -h @SOCKETDIR@ -X -c \"%s\" \"%s\"" SYSTEMQUOTE,
psqldir ? psqldir : "",
psqldir ? "/" : "",
query_escaped,
-@@ -2207,8 +2207,8 @@
+@@ -2201,7 +2201,7 @@
* Check if there is a postmaster running already.
*/
snprintf(buf2, sizeof(buf2),
- SYSTEMQUOTE "\"%s/psql\" -X postgres <%s 2>%s" SYSTEMQUOTE,
-- bindir, DEVNULL, DEVNULL);
-+ SYSTEMQUOTE "\"%s/psql\" -h @SOCKETDIR@ -X postgres <%s 2>%s" SYSTEMQUOTE,
-+ psqldir, DEVNULL, DEVNULL);
++ SYSTEMQUOTE "\"%s/psql\" -h @SOCKETDIR@ -X postgres <%s 2>%s" SYSTEMQUOTE,
+ bindir, DEVNULL, DEVNULL);
for (i = 0; i < 16; i++)
- {
-@@ -2239,7 +2239,7 @@
+@@ -2233,7 +2233,7 @@
*/
header(_("starting postmaster"));
snprintf(buf, sizeof(buf),
- SYSTEMQUOTE "\"%s/postgres\" -D \"%s/data\" -F%s -c \"listen_addresses=%s\" > \"%s/log/postmaster.log\" 2>&1" SYSTEMQUOTE,
-+ SYSTEMQUOTE "\"%s/postgres\" -k @SOCKETDIR@ -D \"%s/data\" -F%s -c \"listen_addresses=%s\" > \"%s/log/postmaster.log\" 2>&1" SYSTEMQUOTE,
++ SYSTEMQUOTE "\"%s/postgres\" -k @SOCKETDIR@ -D \"%s/data\" -F%s -c \"listen_addresses=%s\" > \"%s/log/postmaster.log\" 2>&1" SYSTEMQUOTE,
bindir, temp_install,
debug ? " -d 5" : "",
hostname ? hostname : "",
-diff -Naur a/src/test/regress/pg_regress_main.c b/src/test/regress/pg_regress_main.c
---- a/src/test/regress/pg_regress_main.c 2011-04-27 17:17:22.000000000 -0400
-+++ b/src/test/regress/pg_regress_main.c 2011-05-02 19:02:23.571086780 -0400
+diff -Naurw a/src/test/regress/pg_regress_main.c b/src/test/regress/pg_regress_main.c
+--- a/src/test/regress/pg_regress_main.c 2012-05-10 18:35:09.000000000 -0400
++++ b/src/test/regress/pg_regress_main.c 2012-05-20 09:57:41.523599810 -0400
@@ -64,7 +64,7 @@
"%s ", launcher);
snprintf(psql_cmd + offset, sizeof(psql_cmd) - offset,
- SYSTEMQUOTE "\"%s%spsql\" -X -a -q -d \"%s\" < \"%s\" > \"%s\" 2>&1" SYSTEMQUOTE,
-+ SYSTEMQUOTE "\"%s%spsql\" -h @SOCKETDIR@ -X -a -q -d \"%s\" < \"%s\" > \"%s\" 2>&1" SYSTEMQUOTE,
++ SYSTEMQUOTE "\"%s%spsql\" -h @SOCKETDIR@ -X -a -q -d \"%s\" < \"%s\" > \"%s\" 2>&1" SYSTEMQUOTE,
psqldir ? psqldir : "",
psqldir ? "/" : "",
dblist->str,
diff --git a/server.patch b/server.patch
index a9e7ce9..05f06b2 100644
--- a/server.patch
+++ b/server.patch
@@ -1,6 +1,6 @@
diff -Naur a/contrib/adminpack/Makefile b/contrib/adminpack/Makefile
---- a/contrib/adminpack/Makefile 2011-09-08 17:13:27.000000000 -0400
-+++ b/contrib/adminpack/Makefile 2011-09-17 11:42:03.576618001 -0400
+--- a/contrib/adminpack/Makefile 2012-05-10 18:35:09.000000000 -0400
++++ b/contrib/adminpack/Makefile 2012-05-20 10:02:56.705637432 -0400
@@ -2,7 +2,7 @@
MODULE_big = adminpack
@@ -11,8 +11,8 @@ diff -Naur a/contrib/adminpack/Makefile b/contrib/adminpack/Makefile
EXTENSION = adminpack
DATA = adminpack--1.0.sql
diff -Naur a/contrib/dblink/Makefile b/contrib/dblink/Makefile
---- a/contrib/dblink/Makefile 2011-09-08 17:13:27.000000000 -0400
-+++ b/contrib/dblink/Makefile 2011-09-17 11:42:44.500618001 -0400
+--- a/contrib/dblink/Makefile 2012-05-10 18:35:09.000000000 -0400
++++ b/contrib/dblink/Makefile 2012-05-20 10:03:36.338139189 -0400
@@ -2,7 +2,7 @@
MODULE_big = dblink
@@ -23,8 +23,8 @@ diff -Naur a/contrib/dblink/Makefile b/contrib/dblink/Makefile
SHLIB_PREREQS = submake-libpq
diff -Naur a/contrib/Makefile b/contrib/Makefile
---- a/contrib/Makefile 2011-09-08 17:13:27.000000000 -0400
-+++ b/contrib/Makefile 2011-09-17 11:44:08.068618001 -0400
+--- a/contrib/Makefile 2012-05-10 18:35:09.000000000 -0400
++++ b/contrib/Makefile 2012-05-20 10:05:21.330819252 -0400
@@ -26,7 +26,6 @@
isn \
lo \
@@ -33,7 +33,7 @@ diff -Naur a/contrib/Makefile b/contrib/Makefile
pageinspect \
passwordcheck \
pg_archivecleanup \
-@@ -38,7 +37,6 @@
+@@ -39,7 +38,6 @@
pg_trgm \
pg_upgrade \
pg_upgrade_support \
@@ -41,8 +41,8 @@ diff -Naur a/contrib/Makefile b/contrib/Makefile
pgcrypto \
pgrowlocks \
pgstattuple \
-@@ -47,8 +45,7 @@
- tablefunc \
+@@ -49,8 +47,7 @@
+ tcn \
test_parser \
tsearch2 \
- unaccent \
@@ -52,15 +52,9 @@ diff -Naur a/contrib/Makefile b/contrib/Makefile
ifeq ($(with_openssl),yes)
SUBDIRS += sslinfo
diff -Naur a/contrib/uuid-ossp/Makefile b/contrib/uuid-ossp/Makefile
---- a/contrib/uuid-ossp/Makefile 2011-09-08 17:13:27.000000000 -0400
-+++ b/contrib/uuid-ossp/Makefile 2011-09-17 11:45:18.240618001 -0400
-@@ -1,12 +1,13 @@
- # contrib/uuid-ossp/Makefile
-
-+PG_CPPFLAGS += "-DHAVE_OSSP_UUID_H"
- MODULE_big = uuid-ossp
- OBJS = uuid-ossp.o
-
+--- a/contrib/uuid-ossp/Makefile 2012-05-10 18:35:09.000000000 -0400
++++ b/contrib/uuid-ossp/Makefile 2012-05-20 10:06:57.251613365 -0400
+@@ -6,7 +6,7 @@
EXTENSION = uuid-ossp
DATA = uuid-ossp--1.0.sql uuid-ossp--unpackaged--1.0.sql
@@ -70,8 +64,8 @@ diff -Naur a/contrib/uuid-ossp/Makefile b/contrib/uuid-ossp/Makefile
ifdef USE_PGXS
PG_CONFIG = pg_config
diff -Naur a/contrib/xml2/Makefile b/contrib/xml2/Makefile
---- a/contrib/xml2/Makefile 2011-09-08 17:13:27.000000000 -0400
-+++ b/contrib/xml2/Makefile 2011-09-17 11:46:25.216618000 -0400
+--- a/contrib/xml2/Makefile 2012-05-10 18:35:09.000000000 -0400
++++ b/contrib/xml2/Makefile 2012-05-20 10:07:40.202073404 -0400
@@ -8,7 +8,8 @@
REGRESS = xml2
@@ -83,8 +77,8 @@ diff -Naur a/contrib/xml2/Makefile b/contrib/xml2/Makefile
ifdef USE_PGXS
PG_CONFIG = pg_config
diff -Naur a/GNUmakefile.in b/GNUmakefile.in
---- a/GNUmakefile.in 2011-09-08 17:13:27.000000000 -0400
-+++ b/GNUmakefile.in 2011-09-17 11:48:36.620618001 -0400
+--- a/GNUmakefile.in 2012-05-10 18:35:09.000000000 -0400
++++ b/GNUmakefile.in 2012-05-20 10:09:31.035680036 -0400
@@ -8,7 +8,7 @@
top_builddir = .
include $(top_builddir)/src/Makefile.global
@@ -121,20 +115,20 @@ diff -Naur a/GNUmakefile.in b/GNUmakefile.in
$(call recurse,distprep,doc src config contrib)
diff -Naur a/src/bin/initdb/Makefile b/src/bin/initdb/Makefile
---- a/src/bin/initdb/Makefile 2011-09-08 17:13:27.000000000 -0400
-+++ b/src/bin/initdb/Makefile 2011-09-17 11:50:16.832618001 -0400
+--- a/src/bin/initdb/Makefile 2012-05-10 18:35:09.000000000 -0400
++++ b/src/bin/initdb/Makefile 2012-05-20 10:11:07.706464719 -0400
@@ -16,7 +16,7 @@
top_builddir = ../../..
include $(top_builddir)/src/Makefile.global
--override CPPFLAGS := -DFRONTEND -I$(libpq_srcdir) $(CPPFLAGS)
-+override CPPFLAGS := -DFRONTEND -I$(top_srcdir)/src/interfaces/libpq $(CPPFLAGS)
-
- OBJS= initdb.o encnames.o pqsignal.o $(WIN32RES)
+-override CPPFLAGS := -DFRONTEND -I$(libpq_srcdir) -I$(top_srcdir)/src/timezone $(CPPFLAGS)
++override CPPFLAGS := -DFRONTEND -I$(top_srcdir)/src/interfaces/libpq -I$(top_srcdir)/src/timezone $(CPPFLAGS)
+ # use system timezone data?
+ ifneq (,$(with_system_tzdata))
diff -Naur a/src/bin/Makefile b/src/bin/Makefile
---- a/src/bin/Makefile 2011-09-08 17:13:27.000000000 -0400
-+++ b/src/bin/Makefile 2011-09-17 11:51:14.628618001 -0400
+--- a/src/bin/Makefile 2012-05-10 18:35:09.000000000 -0400
++++ b/src/bin/Makefile 2012-05-20 10:12:05.619736652 -0400
@@ -13,8 +13,7 @@
top_builddir = ../..
include $(top_builddir)/src/Makefile.global
@@ -146,9 +140,9 @@ diff -Naur a/src/bin/Makefile b/src/bin/Makefile
ifeq ($(PORTNAME), win32)
SUBDIRS += pgevent
diff -Naur a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
---- a/src/include/pg_config_manual.h 2011-09-08 17:13:27.000000000 -0400
-+++ b/src/include/pg_config_manual.h 2011-09-17 11:52:23.292618001 -0400
-@@ -141,7 +141,7 @@
+--- a/src/include/pg_config_manual.h 2012-05-10 18:35:09.000000000 -0400
++++ b/src/include/pg_config_manual.h 2012-05-20 10:13:33.358633625 -0400
+@@ -144,7 +144,7 @@
* here's where to twiddle it. You can also override this at runtime
* with the postmaster's -k switch.
*/
@@ -158,8 +152,8 @@ diff -Naur a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
/*
* The random() function is expected to yield values between 0 and
diff -Naur a/src/Makefile b/src/Makefile
---- a/src/Makefile 2011-09-08 17:13:27.000000000 -0400
-+++ b/src/Makefile 2011-09-17 12:12:29.580618000 -0400
+--- a/src/Makefile 2012-05-10 18:35:09.000000000 -0400
++++ b/src/Makefile 2012-05-20 10:15:28.923180781 -0400
@@ -18,12 +18,9 @@
backend \
backend/utils/mb/conversion_procs \
@@ -183,8 +177,8 @@ diff -Naur a/src/Makefile b/src/Makefile
install-local: installdirs-local
$(INSTALL_DATA) Makefile.global '$(DESTDIR)$(pgxsdir)/$(subdir)/Makefile.global'
diff -Naur a/src/Makefile.global.in b/src/Makefile.global.in
---- a/src/Makefile.global.in 2011-09-08 17:13:27.000000000 -0400
-+++ b/src/Makefile.global.in 2011-09-17 12:14:57.972618000 -0400
+--- a/src/Makefile.global.in 2012-05-10 18:35:09.000000000 -0400
++++ b/src/Makefile.global.in 2012-05-20 10:16:23.701492126 -0400
@@ -482,6 +482,7 @@
LDFLAGS += $(PROFILE)
endif
@@ -194,8 +188,8 @@ diff -Naur a/src/Makefile.global.in b/src/Makefile.global.in
##########################################################################
#
diff -Naur a/src/port/Makefile b/src/port/Makefile
---- a/src/port/Makefile 2011-09-08 17:13:27.000000000 -0400
-+++ b/src/port/Makefile 2011-09-17 12:15:46.196618001 -0400
+--- a/src/port/Makefile 2012-05-10 18:35:09.000000000 -0400
++++ b/src/port/Makefile 2012-05-20 10:18:09.773158623 -0400
@@ -37,11 +37,10 @@
# foo_srv.o and foo.o are both built from foo.c, but only foo.o has -DFRONTEND
OBJS_SRV = $(OBJS:%.o=%_srv.o)