summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/moonscript')
-rw-r--r--dev-lua/moonscript/moonscript-9999.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-lua/moonscript/moonscript-9999.ebuild b/dev-lua/moonscript/moonscript-9999.ebuild
index ff2671b..bbb9a33 100644
--- a/dev-lua/moonscript/moonscript-9999.ebuild
+++ b/dev-lua/moonscript/moonscript-9999.ebuild
@@ -1,16 +1,15 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
+
+VCS="git"
+GITHUB_A="leafo"
-VCS="git-r3"
inherit lua
DESCRIPTION="A programmer friendly language that compiles into Lua."
HOMEPAGE="https://github.com/leafo/moonscript"
-SRC_URI=""
-
-EGIT_REPO_URI="https://github.com/leafo/moonscript"
LICENSE="MIT"
SLOT="0"
@@ -28,7 +27,7 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
-DOCS=( docs/. README.md )
+DOCS=(docs/. README.md)
each_lua_compile() {
local lua="$(lua_get_implementation)"