summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <mva@mva.name>2013-04-06 14:37:45 +0700
committerVadim A. Misbakh-Soloviov <mva@mva.name>2013-04-06 14:37:45 +0700
commit7db720a12619e316826c5a8d1eb23f0fd238ef72 (patch)
tree02ee7e1638ff629f99abe12c8793224e138afdfc /dev-lua/profi
parent[dev-lua/ljsyscall] added (diff)
downloadlua-7db720a12619e316826c5a8d1eb23f0fd238ef72.tar.gz
lua-7db720a12619e316826c5a8d1eb23f0fd238ef72.tar.bz2
lua-7db720a12619e316826c5a8d1eb23f0fd238ef72.zip
[dev-lua/profi] added
Signed-off-by: Vadim A. Misbakh-Soloviov <mva@mva.name>
Diffstat (limited to 'dev-lua/profi')
-rw-r--r--dev-lua/profi/Manifest1
-rw-r--r--dev-lua/profi/metadata.xml14
-rw-r--r--dev-lua/profi/profi-12.ebuild29
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-lua/profi/Manifest b/dev-lua/profi/Manifest
new file mode 100644
index 0000000..426c1de
--- /dev/null
+++ b/dev-lua/profi/Manifest
@@ -0,0 +1 @@
+DIST profi-12.tar.gz 3909 SHA256 a90e19e6f626514d2b3da5ff3bfde6370e48ec6d264b965ab704ddb92fef49b8 SHA512 da555562f125322f6c20bbb182c1dd893b9e7eee3bb448b856d63c01eacbcb11dc5142bc77992b3d6128d4a03d8277c34d0befe755c380b75ffd290d082a0bd6 WHIRLPOOL 314ccefcfdbdb5856e654505d1d1898bc26b6483e86ec4c339c521f116ea979e70d0c1029e33790c528cad8c8db758f8d9c0ade1066e21fc3cbe303d136af85e
diff --git a/dev-lua/profi/metadata.xml b/dev-lua/profi/metadata.xml
new file mode 100644
index 0000000..23da526
--- /dev/null
+++ b/dev-lua/profi/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mva@mva.name</email>
+ <description>
+ If you have any issues, please contact me, or try to find me in IRC on Freenode, OFTC or RusNet.
+ </description>
+ <name>Vadim A. Misbakh-Soloviov</name>
+</maintainer>
+<longdescription>FIXME</longdescription>
+<use>
+</use>
+</pkgmetadata>
diff --git a/dev-lua/profi/profi-12.ebuild b/dev-lua/profi/profi-12.ebuild
new file mode 100644
index 0000000..2ebd29d
--- /dev/null
+++ b/dev-lua/profi/profi-12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: This ebuild is from Lua overlay; Bumped by mva; $
+
+EAPI="5"
+
+inherit eutils vcs-snapshot
+
+DESCRIPTION="a Lua Profiler"
+HOMEPAGE="https://gist.github.com/perky/2838755"
+SRC_URI="https://gist.github.com/perky/2838755/download -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="x86 amd64 ppc mips arm"
+IUSE="luajit"
+
+RDEPEND="
+ || ( virtual/lua dev-lang/luajit:2 =dev-lang/lua-5.1* )
+ virtual/pkgconfig
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ local lua=lua;
+ use luajit && lua=luajit
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD ${lua})"
+ doins ProFi.lua
+}