summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <git@mva.name>2015-09-30 13:39:45 +0600
committerVadim A. Misbakh-Soloviov <git@mva.name>2015-09-30 13:39:45 +0600
commit43b29c34f682cbde48f23c42fd13d334d7bb425c (patch)
treebcc77aff84dfb5e8659e05a8aec694cb32f6a2f2 /dev-lua/luazip
parenteclass/lua: added; dev-lua/*: moving to lua eclass (diff)
downloadlua-43b29c34f682cbde48f23c42fd13d334d7bb425c.tar.gz
lua-43b29c34f682cbde48f23c42fd13d334d7bb425c.tar.bz2
lua-43b29c34f682cbde48f23c42fd13d334d7bb425c.zip
some more work about porting to lua eclass
Signed-off-by: Vadim A. Misbakh-Soloviov <git@mva.name>
Diffstat (limited to 'dev-lua/luazip')
-rw-r--r--dev-lua/luazip/luazip-9999.ebuild44
1 files changed, 29 insertions, 15 deletions
diff --git a/dev-lua/luazip/luazip-9999.ebuild b/dev-lua/luazip/luazip-9999.ebuild
index 0196764..cd4cb4e 100644
--- a/dev-lua/luazip/luazip-9999.ebuild
+++ b/dev-lua/luazip/luazip-9999.ebuild
@@ -4,33 +4,47 @@
EAPI="5"
-inherit git-r3 toolchain-funcs
+VCS="git-r3"
+
+# FIXME
+#IS_MULTILIB=true
+inherit lua
+
DESCRIPTION="Lua bindings to zziplib"
-HOMEPAGE="https://github.com/luaforge/luazip"
-EGIT_REPO_URI="https://github.com/luaforge/luazip.git"
+HOMEPAGE="https://github.com/msva/luazip"
+EGIT_REPO_URI="https://github.com/msva/luazip"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-IUSE="luajit"
+IUSE="doc +examples"
RDEPEND="
- virtual/lua[luajit=]
dev-libs/zziplib
"
DEPEND="
${RDEPEND}
- virtual/pkgconfig
"
-src_configure() {
- local lua=lua;
- use luajit && lua=luajit;
- sed -r \
- -e "s#(LUA_INC)=.*#\1=$($(tc-getPKG_CONFIG) --variable includedir ${lua})#" \
- -e 's#(PREFIX) =.*#\1=$(DESTDIR)/usr#' \
- -e "s#(ZZLIB_INC)=.*#\1=/usr/include#" \
- -e "s#(LUA_VERSION_NUM)=.*#\1=510#" \
- -i config
+READMES=( README )
+HTML_DOCS=( doc/us/ )
+EXAMPLES=( tests/ )
+
+all_lua_prepare() {
+ sed -i -e 'd' config
+ lua_default
+}
+
+each_lua_configure() {
+ myeconfargs=()
+ myeconfargs+=(
+ 'LIB_OPTION=$(LDFLAGS)'
+ 'LIBNAME=zip.so'
+ )
+ lua_default
+}
+
+each_lua_install() {
+ dolua src/*.so
}