aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
m---------.gnulib0
-rwxr-xr-xbootstrap12
-rw-r--r--bootstrap.conf2
-rw-r--r--configure.ac2
4 files changed, 12 insertions, 4 deletions
diff --git a/.gnulib b/.gnulib
-Subproject f15a17dc1f5d2b1fc8a423795c54b211552c048
+Subproject bb2f5640d5379c5b4eec2d62341413bbab1aa30
diff --git a/bootstrap b/bootstrap
index 5aa73cc1b..6b458689b 100755
--- a/bootstrap
+++ b/bootstrap
@@ -1,6 +1,6 @@
#! /bin/sh
# Print a version string.
-scriptversion=2012-04-19.22; # UTC
+scriptversion=2012-04-25.17; # UTC
# Bootstrap this package from checked-out sources.
@@ -873,7 +873,15 @@ if test $with_gettext = yes; then
}
' po/Makevars.template >po/Makevars || exit 1
- cat $GNULIB_SRCDIR/build-aux/po/Makefile.in.in > po/Makefile.in.in || exit 1
+ # If the 'gettext' module is in use, grab the latest Makefile.in.in.
+ # If only the 'gettext-h' module is in use, assume autopoint already
+ # put the correct version of this file into place.
+ case $gnulib_modules in
+ *gettext-h*) ;;
+ *gettext*)
+ cp $GNULIB_SRCDIR/build-aux/po/Makefile.in.in po/Makefile.in.in || exit 1
+ ;;
+ esac
if test -d runtime-po; then
# Similarly for runtime-po/Makevars, but not quite the same.
diff --git a/bootstrap.conf b/bootstrap.conf
index 56911e02c..c6620e5c0 100644
--- a/bootstrap.conf
+++ b/bootstrap.conf
@@ -195,7 +195,7 @@ buildreq="\
autoconf 2.59
automake 1.9.6
autopoint -
-gettext 0.18
+gettext 0.17
git 1.5.5
gzip -
libtool -
diff --git a/configure.ac b/configure.ac
index 5936d3113..89fe81835 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2300,7 +2300,7 @@ dnl compute the difference between save_CPPFLAGS and CPPFLAGS and append it
dnl to INCLUDES in order to preserve changes made by gettext but in a place
dnl that does not break the build
save_CPPFLAGS="$CPPFLAGS"
-AM_GNU_GETTEXT_VERSION([0.18])
+AM_GNU_GETTEXT_VERSION([0.17])
AM_GNU_GETTEXT([external])
GETTEXT_CPPFLAGS=
if test "x$save_CPPFLAGS" != "x$CPPFLAGS"; then