summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWido den Hollander <wido@widodh.nl>2012-05-14 11:06:42 +0200
committerEric Blake <eblake@redhat.com>2012-05-21 12:37:38 -0600
commit74951eadef85e2d100c7dc7bd9ae1093fbda722f (patch)
tree63ec5dfe198ae5178164e663eaa5d6e47578eaeb /libvirt.spec.in
parentbuild: fix unused variable after last patch (diff)
downloadlibvirt-74951eadef85e2d100c7dc7bd9ae1093fbda722f.tar.gz
libvirt-74951eadef85e2d100c7dc7bd9ae1093fbda722f.tar.bz2
libvirt-74951eadef85e2d100c7dc7bd9ae1093fbda722f.zip
storage backend: Add RBD (RADOS Block Device) support
This patch adds support for a new storage backend with RBD support. RBD is the RADOS Block Device and is part of the Ceph distributed storage system. It comes in two flavours: Qemu-RBD and Kernel RBD, this storage backend only supports Qemu-RBD, thus limiting the use of this storage driver to Qemu only. To function this backend relies on librbd and librados being present on the local system. The backend also supports Cephx authentication for safe authentication with the Ceph cluster. For storing credentials it uses the built-in secret mechanism of libvirt. Signed-off-by: Wido den Hollander <wido@widodh.nl>
Diffstat (limited to 'libvirt.spec.in')
-rw-r--r--libvirt.spec.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/libvirt.spec.in b/libvirt.spec.in
index eef8ce160..8c4a2fd2a 100644
--- a/libvirt.spec.in
+++ b/libvirt.spec.in
@@ -73,6 +73,9 @@
%define with_storage_iscsi 0%{!?_without_storage_iscsi:%{server_drivers}}
%define with_storage_disk 0%{!?_without_storage_disk:%{server_drivers}}
%define with_storage_mpath 0%{!?_without_storage_mpath:%{server_drivers}}
+%if 0%{?fedora} >= 16
+%define with_storage_rbd 0%{!?_without_storage_rbd:%{server_drivers}}
+%endif
%define with_numactl 0%{!?_without_numactl:%{server_drivers}}
%define with_selinux 0%{!?_without_selinux:%{server_drivers}}
@@ -215,6 +218,7 @@
%define with_storage_lvm 0
%define with_storage_iscsi 0
%define with_storage_mpath 0
+%define with_storage_rbd 0
%define with_storage_disk 0
%endif
@@ -407,6 +411,9 @@ BuildRequires: device-mapper
%else
BuildRequires: device-mapper-devel
%endif
+%if %{with_storage_rbd}
+BuildRequires: ceph-devel
+%endif
%endif
%if %{with_numactl}
# For QEMU/LXC numa info
@@ -560,6 +567,10 @@ Requires: device-mapper
# For multipath support
Requires: device-mapper
%endif
+%if %{with_storage_rbd}
+# For RBD support
+Requires: ceph
+%endif
%if %{with_cgconfig}
Requires: libcgroup
%endif
@@ -840,6 +851,10 @@ of recent versions of Linux (and other OSes).
%define _without_storage_mpath --without-storage-mpath
%endif
+%if ! %{with_storage_rbd}
+%define _without_storage_rbd --without-storage-rbd
+%endif
+
%if ! %{with_numactl}
%define _without_numactl --without-numactl
%endif
@@ -933,6 +948,7 @@ autoreconf -if
%{?_without_storage_iscsi} \
%{?_without_storage_disk} \
%{?_without_storage_mpath} \
+ %{?_without_storage_rbd} \
%{?_without_numactl} \
%{?_without_numad} \
%{?_without_capng} \