aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2012-09-14 10:08:54 +0100
committerRichard W.M. Jones <rjones@redhat.com>2012-09-18 10:59:16 +0100
commit5090c576e3a76727c39a9b3221b2e82b545bc983 (patch)
tree8cc8b6b146b02fca04c0d20c346feef46b05d589 /configure.ac
parentrpc: Fix name of member in remote_protocol-structs (diff)
downloadlibvirt-5090c576e3a76727c39a9b3221b2e82b545bc983.tar.gz
libvirt-5090c576e3a76727c39a9b3221b2e82b545bc983.tar.bz2
libvirt-5090c576e3a76727c39a9b3221b2e82b545bc983.zip
Add a ./run script for running programs from the local directory.
With this script you can run libvirt programs without needing to install them first. You just have to do for example: ./run ./tools/virsh [args ...] If you are already in the tools/ subdirectory, then the following command will also work: ../run ./virsh [...] You can also run the C programs under valgrind like this: ./run valgrind [valgrind opts...] ./program or under gdb: ./run gdb --args ./program This also works with sudo (eg. if you need root access for libvirt): sudo ./run ./tools/virsh list --all Derived from libguestfs and simplified. The ./run script in libguestfs is much more sophisticated: https://github.com/libguestfs/libguestfs/blob/master/run.in
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2090e5f6a..186f79e87 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2972,6 +2972,8 @@ AC_DEFINE_UNQUOTED([isbase64],[libvirt_gl_isbase64],[Hack to avoid symbol clash]
AC_DEFINE_UNQUOTED([base64_encode],[libvirt_gl_base64_encode],[Hack to avoid symbol clash])
AC_DEFINE_UNQUOTED([base64_encode_alloc],[libvirt_gl_base64_encode_alloc],[Hack to avoid symbol clash])
+AC_CONFIG_FILES([run],
+ [chmod +x,-w run])
AC_OUTPUT(Makefile src/Makefile include/Makefile docs/Makefile \
docs/schemas/Makefile \
gnulib/lib/Makefile \