aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2012-04-19 17:04:00 -0600
committerEric Blake <eblake@redhat.com>2012-04-19 17:11:43 -0600
commitc9cd419caba9effa11ca53e8696e5f6a4b424d60 (patch)
tree503991d806225291cd6b2bae6ce64c9c45b5fb3e /bootstrap
parentvirsh: avoid uninitialized memory usage (diff)
downloadlibvirt-c9cd419caba9effa11ca53e8696e5f6a4b424d60.tar.gz
libvirt-c9cd419caba9effa11ca53e8696e5f6a4b424d60.tar.bz2
libvirt-c9cd419caba9effa11ca53e8696e5f6a4b424d60.zip
build: fix fresh checkout on RHEL5
Building a fresh checkout on RHEL 5 has been broken since commit 29db7a00, due to a gnulib regression in the bootstrap script (incremental builds from a checkout earlier than that point were okay, though). * .gnulib: Update to latest, for bootstrap fixes. * bootstrap: Resync from gnulib. * gnulib/local/top/maint.mk.diff: Drop patch that was added upstream in the meantime.
Diffstat (limited to 'bootstrap')
-rwxr-xr-xbootstrap18
1 files changed, 15 insertions, 3 deletions
diff --git a/bootstrap b/bootstrap
index 31eb651f6..5aa73cc1b 100755
--- a/bootstrap
+++ b/bootstrap
@@ -1,6 +1,6 @@
#! /bin/sh
# Print a version string.
-scriptversion=2012-02-11.09; # UTC
+scriptversion=2012-04-19.22; # UTC
# Bootstrap this package from checked-out sources.
@@ -36,6 +36,10 @@ nl='
LC_ALL=C
export LC_ALL
+# Ensure that CDPATH is not set. Otherwise, the output from cd
+# would cause trouble in at least one use below.
+(unset CDPATH) >/dev/null 2>&1 && unset CDPATH
+
local_gl_dir=gl
me=$0
@@ -758,9 +762,15 @@ fi
# Autoreconf runs aclocal before libtoolize, which causes spurious
# warnings if the initial aclocal is confused by the libtoolized
# (or worse out-of-date) macro directory.
+# libtoolize 1.9b added the --install option; but we support back
+# to libtoolize 1.5.22, where the install action was default.
if test $use_libtool = 1; then
- echo "running: $LIBTOOLIZE --copy --install"
- $LIBTOOLIZE --copy --install
+ install=
+ case $($LIBTOOLIZE --help) in
+ *--install*) install=--install ;;
+ esac
+ echo "running: $LIBTOOLIZE $install --copy"
+ $LIBTOOLIZE $install --copy
fi
version_controlled_file() {
@@ -863,6 +873,8 @@ if test $with_gettext = yes; then
}
' po/Makevars.template >po/Makevars || exit 1
+ cat $GNULIB_SRCDIR/build-aux/po/Makefile.in.in > po/Makefile.in.in || exit 1
+
if test -d runtime-po; then
# Similarly for runtime-po/Makevars, but not quite the same.
rm -f runtime-po/Makevars