aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-08-15 15:43:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-08-15 15:44:29 +0200
commitfdbafc16f664ad6ae17906ad7d7c70e872198fad (patch)
treedcc6e9fa622d1280a35a37d4681f71654640067f /net-irc
parentkde-frameworks/kconfig: Fix IUSE qml (diff)
downloadkde-fdbafc16f664ad6ae17906ad7d7c70e872198fad.tar.gz
kde-fdbafc16f664ad6ae17906ad7d7c70e872198fad.tar.bz2
kde-fdbafc16f664ad6ae17906ad7d7c70e872198fad.zip
net-irc/konversation: drop 2.9999, branch wip/qtquick is dead
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/konversation/files/konversation-2.9999-unused-kemoticons.patch112
-rw-r--r--net-irc/konversation/konversation-2.9999.ebuild82
2 files changed, 0 insertions, 194 deletions
diff --git a/net-irc/konversation/files/konversation-2.9999-unused-kemoticons.patch b/net-irc/konversation/files/konversation-2.9999-unused-kemoticons.patch
deleted file mode 100644
index 742038b551..0000000000
--- a/net-irc/konversation/files/konversation-2.9999-unused-kemoticons.patch
+++ /dev/null
@@ -1,112 +0,0 @@
-From 271da4bd1e584026fc24d93474ca6cf9e50fa6d7 Mon Sep 17 00:00:00 2001
-From: David Edmundson <kde@davidedmundson.co.uk>
-Date: Mon, 16 Sep 2019 18:18:49 +0100
-Subject: Drop effectively unused kemoticons support
-
-Summary:
-Konversation only supported emoticons if config value EnableEmotIcons
-was true. This by default was false and there is no UI for configuring
-this, making it effectively unused.
-
-This appears to be deliberate from the code comments.
-
-This helps clear up some KEmoticon library usage for future KF6
-transitioning.
-
-UTF-8 emoticons work correctly.
-
-Test Plan: Compiles
-
-Differential Revision: https://phabricator.kde.org/D24000
----
- src/CMakeLists.txt | 2 --
- src/config/konversation.kcfg | 8 --------
- src/viewer/ircview.cpp | 3 ---
- 3 files changed, 13 deletions(-)
-
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index c2077b3..89616a6 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -138,7 +138,6 @@ set(viewer_SRCS
- viewer/topiclabel.cpp
- viewer/awaylabel.cpp
- viewer/editnotifydialog.cpp
-- viewer/emoticons.cpp
- viewer/images.cpp
- viewer/quickbutton.cpp
- viewer/searchbar.cpp
-@@ -224,7 +223,6 @@ target_link_libraries(konversation
- KF5::Bookmarks
- KF5::ConfigWidgets
- KF5::Crash
-- KF5::Emoticons
- KF5::I18n
- KF5::IdleTime
- KF5::NotifyConfig
-diff --git a/src/config/konversation.kcfg b/src/config/konversation.kcfg
-index 1d59eaf..3f0b7a6 100644
---- a/src/config/konversation.kcfg
-+++ b/src/config/konversation.kcfg
-@@ -844,14 +844,6 @@
- <label></label>
- <whatsthis></whatsthis>
- </entry>
-- <entry key="EnableEmotIcons" type="Bool">
-- <default>false</default>
-- <label>Enable emoticons</label>
-- </entry>
-- <entry key="EmotIconTheme" type="String">
-- <default>Default</default>
-- <label>Emoticons theme</label>
-- </entry>
- </group>
- <group name="PreferencesDialog">
- <entry name="PreferencesDialogSize" key="Size" type="Size">
-diff --git a/src/viewer/ircview.cpp b/src/viewer/ircview.cpp
-index c129f61..15f78ca 100644
---- a/src/viewer/ircview.cpp
-+++ b/src/viewer/ircview.cpp
-@@ -20,7 +20,6 @@
- #include "application.h"
- #include "highlight.h"
- #include "sound.h"
--#include "emoticons.h"
- #include "notificationhandler.h"
-
- #include <QDrag>
-@@ -1214,8 +1213,6 @@ QString IRCView::filter(const QString& line, const QString& defaultColor, const
- QLatin1String("\">") + filteredLine + QLatin1String("</font>");
- }
-
-- filteredLine = Konversation::Emoticons::parseEmoticons(filteredLine);
--
- return filteredLine;
- }
-
---
-cgit v1.1
-
-From f1e6ec37b9a9ead194606795ed23a1ec70a784cc Mon Sep 17 00:00:00 2001
-From: Peter Simonsson <peter.simonsson@gmail.com>
-Date: Tue, 7 Apr 2020 16:37:53 +0200
-Subject: Remove KEmoticons from dependencies as it's not used
-
----
- CMakeLists.txt | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 5315dbd..19facd8 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -24,7 +24,6 @@ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED
- ConfigWidgets
- CoreAddons
- Crash
-- Emoticons
- I18n
- IdleTime
- NotifyConfig
---
-cgit v1.1
diff --git a/net-irc/konversation/konversation-2.9999.ebuild b/net-irc/konversation/konversation-2.9999.ebuild
deleted file mode 100644
index 1c94e4c55e..0000000000
--- a/net-irc/konversation/konversation-2.9999.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-EGIT_BRANCH="wip/qtquick"
-ECM_HANDBOOK="forceoptional"
-KDE_GEAR="true"
-KFMIN=5.82.0
-QTMIN=5.15.5
-inherit ecm kde.org
-
-DESCRIPTION="User friendly IRC Client"
-HOMEPAGE="https://konversation.kde.org https://apps.kde.org/konversation/"
-
-LICENSE="GPL-2"
-SLOT="5"
-KEYWORDS=""
-IUSE="+crypt"
-
-BDEPEND="sys-devel/gettext"
-DEPEND="
- >=dev-qt/qtdeclarative-${QTMIN}:5
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtnetwork-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtxml-${QTMIN}:5
- >=kde-frameworks/karchive-${KFMIN}:5
- >=kde-frameworks/kbookmarks-${KFMIN}:5
- >=kde-frameworks/kcodecs-${KFMIN}:5
- >=kde-frameworks/kcompletion-${KFMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kconfigwidgets-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/kcrash-${KFMIN}:5
- >=kde-frameworks/kdbusaddons-${KFMIN}:5
- >=kde-frameworks/kglobalaccel-${KFMIN}:5
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kiconthemes-${KFMIN}:5
- >=kde-frameworks/kidletime-${KFMIN}:5
- >=kde-frameworks/kio-${KFMIN}:5
- >=kde-frameworks/kitemmodels-${KFMIN}:5
- >=kde-frameworks/kitemviews-${KFMIN}:5
- >=kde-frameworks/knotifications-${KFMIN}:5
- >=kde-frameworks/knotifyconfig-${KFMIN}:5
- >=kde-frameworks/kpackage-${KFMIN}:5
- >=kde-frameworks/kparts-${KFMIN}:5
- >=kde-frameworks/kservice-${KFMIN}:5
- >=kde-frameworks/ktextwidgets-${KFMIN}:5
- >=kde-frameworks/kwallet-${KFMIN}:5
- >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
- >=kde-frameworks/kwindowsystem-${KFMIN}:5
- >=kde-frameworks/kxmlgui-${KFMIN}:5
- >=media-libs/phonon-4.11.0
- crypt? ( >=app-crypt/qca-2.3.0:2 )
-"
-RDEPEND="${DEPEND}
- >=kde-frameworks/qqc2-desktop-style-${KFMIN}:5
- crypt? ( >=app-crypt/qca-2.3.0:2[ssl] )
-"
-
-PATCHES=(
- # git master
- "${FILESDIR}"/${P}-unused-kemoticons.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package crypt Qca-qt5)
- )
-
- ecm_src_configure
-}
-
-src_install() {
- ecm_src_install
-
- # Bug 616162
- insinto /etc/xdg
- doins "${FILESDIR}"/konversationrc
-}