aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-10-02 23:18:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-10-03 00:15:51 +0200
commit1f1cc85d921dd319355c6df7c6991d8fe7c56ce0 (patch)
treecbc2b2192b587bb6398442d67b5a7ac9e09ac7dd /kde-frameworks
parentkde-frameworks/kidletime: Add IUSE wayland and new dependencies (diff)
downloadkde-1f1cc85d921dd319355c6df7c6991d8fe7c56ce0.tar.gz
kde-1f1cc85d921dd319355c6df7c6991d8fe7c56ce0.tar.bz2
kde-1f1cc85d921dd319355c6df7c6991d8fe7c56ce0.zip
kde-frameworks/kimageformats: Add IUSE raw
Upstream commit 65a20b43fc8b72384534c00cb68d67be6db848f1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kimageformats/kimageformats-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/kde-frameworks/kimageformats/kimageformats-9999.ebuild b/kde-frameworks/kimageformats/kimageformats-9999.ebuild
index 199743d7e1..52ead681ac 100644
--- a/kde-frameworks/kimageformats/kimageformats-9999.ebuild
+++ b/kde-frameworks/kimageformats/kimageformats-9999.ebuild
@@ -10,9 +10,10 @@ VIRTUALX_REQUIRED="test"
inherit ecm frameworks.kde.org
DESCRIPTION="Framework providing additional format plugins for Qt's image I/O system"
+
LICENSE="LGPL-2+"
KEYWORDS=""
-IUSE="avif eps heif jpegxl openexr"
+IUSE="avif eps heif jpegxl openexr raw"
DEPEND="
>=dev-qt/qtgui-${QTMIN}:5
@@ -22,6 +23,7 @@ DEPEND="
heif? ( >=media-libs/libheif-1.10.0:= )
jpegxl? ( media-libs/libjxl )
openexr? ( >=media-libs/openexr-3:= )
+ raw? ( media-libs/libraw:= )
"
RDEPEND="${DEPEND}"
@@ -34,7 +36,7 @@ src_configure() {
$(cmake_use_find_package eps Qt5PrintSupport)
-DKIMAGEFORMATS_HEIF=$(usex heif)
$(cmake_use_find_package openexr OpenEXR)
+ $(cmake_use_find_package raw LibRaw)
)
-
ecm_src_configure
}