aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-10-02 23:53:14 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-10-03 00:17:12 +0200
commit0c0dc021effe0ec53ad5bc9fa871fb79cdbc072a (patch)
tree02341373f11b089b83ee8df0ae8ac213dcec0303 /kde-frameworks
parentkde-frameworks/kcoreaddons: 5.99.0 version bump (diff)
downloadkde-0c0dc021effe0ec53ad5bc9fa871fb79cdbc072a.tar.gz
kde-0c0dc021effe0ec53ad5bc9fa871fb79cdbc072a.tar.bz2
kde-0c0dc021effe0ec53ad5bc9fa871fb79cdbc072a.zip
kde-frameworks/kcrash: 5.99.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kcrash/Manifest1
-rw-r--r--kde-frameworks/kcrash/kcrash-5.99.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-frameworks/kcrash/Manifest b/kde-frameworks/kcrash/Manifest
new file mode 100644
index 0000000000..7feb0ea6d0
--- /dev/null
+++ b/kde-frameworks/kcrash/Manifest
@@ -0,0 +1 @@
+DIST kcrash-5.99.0.tar.xz 28384 BLAKE2B 08f315a6c31cf7818b896abd6c57403941066c5493721550808037e8bc189239c4359ff5f0de38f5af98d85f9411132dc498971b0ef72139f4cbc73b4f1db13e SHA512 1ca52810bcb90ceb5f2416e88694c21db9b70eb8a3b4af121618be32f7ae79b785e6228b61309c1073c11114b5fe0609fe2dae2ba9f0900d6bb75df5ee91aee8
diff --git a/kde-frameworks/kcrash/kcrash-5.99.0.ebuild b/kde-frameworks/kcrash/kcrash-5.99.0.ebuild
new file mode 100644
index 0000000000..bc93f71a3c
--- /dev/null
+++ b/kde-frameworks/kcrash/kcrash-5.99.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for intercepting and handling application crashes"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="nls X"
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ X? (
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ x11-libs/libX11
+ )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+ test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
+"
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_X11=$(usex X)
+ )
+ ecm_src_configure
+}